summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-08-14 09:19:29 -0500
committerMatthias Maier <tamiko@gentoo.org>2015-08-14 09:19:51 -0500
commitf573a07ea65bbbe518d0ce42e0f631630a36069b (patch)
tree15092fffc47de7b4aeeccc3b0bb978e8eb20063f /dev-util/astyle/astyle-2.05.1.ebuild
parentsys-auth/consolekit: Make pm-utils optional (diff)
downloadgentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.tar.gz
gentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.tar.bz2
gentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.zip
dev-util/astyle: version bump to 2.05.1 (bug #530584)
This commit also updates the soname handling (no trailing .0 in soname any more). Special thanks to David Hallas for an initial ebuild update. Gentoo-Bug: 530584 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/astyle/astyle-2.05.1.ebuild')
-rw-r--r--dev-util/astyle/astyle-2.05.1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/astyle/astyle-2.05.1.ebuild b/dev-util/astyle/astyle-2.05.1.ebuild
new file mode 100644
index 000000000000..9a0762b5c9a0
--- /dev/null
+++ b/dev-util/astyle/astyle-2.05.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-opt-2 multilib toolchain-funcs
+
+DESCRIPTION="Artistic Style is a reindenter and reformatter of C++, C and Java source code"
+HOMEPAGE="http://astyle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/astyle/astyle_${PV}_linux.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+IUSE="doc java static-libs"
+
+DEPEND="app-arch/xz-utils
+ java? ( >=virtual/jdk-1.6:= )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ tc-export CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build_system.patch
+ java-pkg-opt-2_src_prepare
+ sed -e "s:^\(JAVAINCS\s*\)=.*$:\1= $(java-pkg_get-jni-cflags):" \
+ -e "s:ar crs:$(tc-getAR) crs:" \
+ -i build/gcc/Makefile || die
+}
+
+src_compile() {
+ emake -f ../build/gcc/Makefile -C src \
+ ${PN} \
+ shared \
+ $(usex java java '') \
+ $(usex static-libs static '')
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/${PN}.h
+
+ pushd src/bin &> /dev/null
+ dobin ${PN}
+
+ dolib.so lib${P}.so
+ dosym lib${P}.so /usr/$(get_libdir)/lib${PN}.so
+ if use java ; then
+ dolib.so lib${P}j.so
+ dosym lib${P}j.so /usr/$(get_libdir)/lib${PN}j.so
+ fi
+ if use static-libs ; then
+ dolib lib${PN}.a
+ fi
+ popd &> /dev/null
+
+ use doc && dohtml doc/*
+}