summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/astyle/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/astyle/files')
-rw-r--r--dev-util/astyle/files/astyle-2.02.1-build_system.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/astyle/files/astyle-2.02.1-build_system.patch b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
new file mode 100644
index 000000000000..1d63a512e9bc
--- /dev/null
+++ b/dev-util/astyle/files/astyle-2.02.1-build_system.patch
@@ -0,0 +1,54 @@
+--- a/build/gcc/Makefile
++++ b/build/gcc/Makefile
+@@ -34,25 +34,25 @@
+ ipath=$(prefix)/bin
+ CBASEFLAGS = -W -Wall -fno-rtti -fno-exceptions
+ JAVAINCS = -I$(JAVA_HOME)/include
+-CXX = g++
++CXX ?= g++
+ INSTALL=install -o $(USER) -g $(USER)
+
+ ##################################################
+
+ # define compile options for each build
+-ifdef CFLAGS
+- CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CFLAGS)
+- CFLAGSd = -g $(CBASEFLAGS) $(CFLAGS)
++ifdef CXXFLAGS
++ CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CXXFLAGS)
++ CFLAGSd = -g $(CBASEFLAGS) $(CXXFLAGS)
+ else
+ CFLAGSr = -DNDEBUG -O3 $(CBASEFLAGS)
+ CFLAGSd = -g $(CBASEFLAGS)
+ endif
+-CFLAGSs = -DASTYLE_LIB -fpic $(CFLAGSr)
+-CFLAGSsd = -DASTYLE_LIB -fpic $(CFLAGSd)
++CFLAGSs = -DASTYLE_LIB -fPIC $(CFLAGSr)
++CFLAGSsd = -DASTYLE_LIB -fPIC $(CFLAGSd)
+ CFLAGSa = -DASTYLE_LIB $(CFLAGSr)
+ CFLAGSad = -DASTYLE_LIB $(CFLAGSd)
+-CFLAGSsj = -DASTYLE_JNI -fpic $(CFLAGSr) $(JAVAINCS)
+-CFLAGSsjd = -DASTYLE_JNI -fpic $(CFLAGSd) $(JAVAINCS)
++CFLAGSsj = -DASTYLE_JNI -fPIC $(CFLAGSr) $(JAVAINCS)
++CFLAGSsjd = -DASTYLE_JNI -fPIC $(CFLAGSd) $(JAVAINCS)
+
+ # define link options
+ ifdef LDFLAGS
+@@ -134,7 +134,7 @@
+ shared: libastyle.so
+ libastyle.so: $(OBJs)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ shareddebug: libastyled.so
+@@ -158,7 +158,7 @@
+ java: libastylej.so
+ libastylej.so: $(OBJsj)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@.0 $(LDFLAGSr) -o $(bindir)/$@.0.0.0 $^
+ @ echo
+
+ javadebug: libastylejd.so