summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bakefile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bakefile')
-rw-r--r--dev-util/bakefile/Manifest1
-rw-r--r--dev-util/bakefile/bakefile-0.2.9-r1.ebuild33
-rw-r--r--dev-util/bakefile/files/bakefile-0.2.6-enlarge-buffers.patch12
-rw-r--r--dev-util/bakefile/metadata.xml8
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/bakefile/Manifest b/dev-util/bakefile/Manifest
new file mode 100644
index 000000000000..279e1b3ba763
--- /dev/null
+++ b/dev-util/bakefile/Manifest
@@ -0,0 +1 @@
+DIST bakefile-0.2.9.tar.gz 775528 SHA256 9f3c65411ad3932027e3c3e765337d89be2f9cf5ee9a204da80e92a8c2d76ca5 SHA512 dc28a3a68c080dababef68b9f39ad141739ecb5e4e1129620274bd80ac13f68cddd6e5625776f23c508f20e1f984a8830a949c425457cfeada8b44081873102f WHIRLPOOL fe050f76f17c1dcce3687eaf7b91cad0cf8b85789cc3a5065ce113b58d0cf9d507c374b3249ecec945086ee666cd9b919bcf6e3d14cc3d0343dce2a3cbaae1e7
diff --git a/dev-util/bakefile/bakefile-0.2.9-r1.ebuild b/dev-util/bakefile/bakefile-0.2.9-r1.ebuild
new file mode 100644
index 000000000000..dc9c677a82e4
--- /dev/null
+++ b/dev-util/bakefile/bakefile-0.2.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 bash-completion-r1
+
+DESCRIPTION="Native makefiles generator"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://bakefile.sourceforge.net"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+src_install () {
+ default
+
+ if use doc ; then
+ dohtml -r doc/html/.
+ fi
+
+ # TODO: symlink the two
+ newbashcomp bash_completion bakefile
+ newbashcomp bash_completion bakefile_gen
+}
diff --git a/dev-util/bakefile/files/bakefile-0.2.6-enlarge-buffers.patch b/dev-util/bakefile/files/bakefile-0.2.6-enlarge-buffers.patch
new file mode 100644
index 000000000000..c0af7bb47bc8
--- /dev/null
+++ b/dev-util/bakefile/files/bakefile-0.2.6-enlarge-buffers.patch
@@ -0,0 +1,12 @@
+diff -urN ./bakefile-0.2.6.orig/src/bottlenecks.c ./bakefile-0.2.6/src/bottlenecks.c
+--- ./bakefile-0.2.6.orig/src/bottlenecks.c 2009-03-26 20:34:42.000000000 +0100
++++ ./bakefile-0.2.6/src/bottlenecks.c 2009-07-21 22:36:18.111411153 +0200
+@@ -37,7 +37,7 @@
+ /* ------------------------------------------------------------------------ */
+
+ #define TEXTBUF_COUNT 8
+-#define TEXTBUF_SIZE 102400
++#define TEXTBUF_SIZE 120000
+
+ static char *textbuf[TEXTBUF_COUNT] =
+ {NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL};
diff --git a/dev-util/bakefile/metadata.xml b/dev-util/bakefile/metadata.xml
new file mode 100644
index 000000000000..c1a4dd3eb2e0
--- /dev/null
+++ b/dev-util/bakefile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <upstream>
+ <remote-id type="sourceforge">bakefile</remote-id>
+ </upstream>
+</pkgmetadata>