summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bam/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bam/files')
-rw-r--r--dev-util/bam/files/0.4.0/Makefile22
-rw-r--r--dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch11
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/bam/files/0.4.0/Makefile b/dev-util/bam/files/0.4.0/Makefile
new file mode 100644
index 000000000000..d64f43abcd11
--- /dev/null
+++ b/dev-util/bam/files/0.4.0/Makefile
@@ -0,0 +1,22 @@
+LIBS += -lm -lpthread -llua -ldl
+TARGETS = txt2c internal_base bam
+BAM_OBJ = $(patsubst %.c,%.o,$(wildcard src/*.c))
+TXT2C_LUA = $(wildcard src/*.lua)
+
+all: $(TARGETS)
+
+txt2c: src/tools/txt2c
+
+internal_base: src/internal_base.h
+
+src/internal_base.h:
+ src/tools/txt2c $(TXT2C_LUA) > src/internal_base.h
+
+bam: txt2c internal_base $(BAM_OBJ)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BAM_OBJ) $(LIBS)
+
+test: $(TARGETS)
+ python scripts/test.py
+
+clean:
+ rm -f $(BAM_OBJ) $(TARGETS) src/internal_base.h src/tools/txt2c
diff --git a/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch b/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch
new file mode 100644
index 000000000000..5ea2acd3e440
--- /dev/null
+++ b/dev-util/bam/files/0.4.0/bam-0.4.0-test.py.patch
@@ -0,0 +1,11 @@
+--- scripts/test.py.old 2010-03-22 19:23:23.000000000 +0100
++++ scripts/test.py 2010-03-22 19:23:43.000000000 +0100
+@@ -178,6 +178,8 @@
+ print "FAILED TESTS:"
+ for t in failed_tests:
+ print "\t"+t
++ sys.exit(1)
+ else:
+ print "ALL TESTS PASSED!"
++ sys.exit(0)
+