summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-08-09 18:52:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-11 10:55:30 +0200
commita4b6849a78ba56eb8916321b6cd3833327a3f6ec (patch)
tree4edb95803e1de7b841afc28779953bf72893b563 /dev-util/bats/bats-0.4.0_p20170219.ebuild
parentdev-util/bats: Add myself as maintainer proxied through Polynomial-C (diff)
downloadgentoo-a4b6849a78ba56eb8916321b6cd3833327a3f6ec.tar.gz
gentoo-a4b6849a78ba56eb8916321b6cd3833327a3f6ec.tar.bz2
gentoo-a4b6849a78ba56eb8916321b6cd3833327a3f6ec.zip
dev-util/bats: Snapshot bump to latest version
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5378
Diffstat (limited to 'dev-util/bats/bats-0.4.0_p20170219.ebuild')
-rw-r--r--dev-util/bats/bats-0.4.0_p20170219.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/bats/bats-0.4.0_p20170219.ebuild b/dev-util/bats/bats-0.4.0_p20170219.ebuild
new file mode 100644
index 000000000000..2abffbaffb56
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0_p20170219.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMITHASH="03608115df2071fff4eaaff1605768c275e5f81f"
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/bats/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/bats-${COMMITHASH}"
+
+src_test() {
+ bin/bats --tap test || die "Tests failed"
+}
+
+src_install() {
+ exeinto /usr/libexec/bats
+ doexe libexec/*
+ dosym ../libexec/bats/bats /usr/bin/bats
+
+ dodoc README.md
+ doman man/bats.1 man/bats.7
+}