summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-02-03 22:22:40 +0800
committerJason Zaman <perfinion@gentoo.org>2019-02-03 22:22:40 +0800
commitb496c130a752b078b6b32b9c08a79347c80cf67d (patch)
tree8af5209d724ff28ceb8e322fbee19b997612ab32 /dev-util/bazel
parentdev-util/bazel: bump to 0.22.0 (diff)
downloadgentoo-b496c130a752b078b6b32b9c08a79347c80cf67d.tar.gz
gentoo-b496c130a752b078b6b32b9c08a79347c80cf67d.tar.bz2
gentoo-b496c130a752b078b6b32b9c08a79347c80cf67d.zip
dev-util/bazel: drop old
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest3
-rw-r--r--dev-util/bazel/bazel-0.17.2.ebuild123
-rw-r--r--dev-util/bazel/bazel-0.18.0.ebuild121
-rw-r--r--dev-util/bazel/bazel-0.19.0.ebuild125
4 files changed, 0 insertions, 372 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index ebcb6de9e27e..a407df48e712 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1,5 +1,2 @@
-DIST bazel-0.17.2-dist.zip 79230155 BLAKE2B 62a60011f9605a1d615e648fdbb98b193561e1d86a7562ccb10fdbb8b6986e17a72c4076dbdbf6baf8a7af83e320af2c4e4b65b5b2101d845597ddd688194ba5 SHA512 0d277e20eac6fc972a31be1c77a750f6585d16beabfe7dd096db4103f0f191958aa83b52203b91d4df5b486ff20004c0b4b22125e58379f64f68abc4a87ac326
-DIST bazel-0.18.0-dist.zip 86890953 BLAKE2B 53da2c2d4467f1f7dd2e613a347acd0ea547bd41fe49fa39cbbcb92c337dca43412ac9b65abf7a3e00c322b8fea075cbdef0da5b064bf4e22aaaa4c545c539de SHA512 128e1041ae0d85be26933bb107b406ca4ab177f00eec2ee1d791ec9089c0cb384857b532498276480d1063b82e7a9a809b9f8a0d0715260534c3e3d202d6cf13
-DIST bazel-0.19.0-dist.zip 87333329 BLAKE2B a9a0002b6a1dc98d3c753b9e37001f41c0e9b3e8628600d10d7ffb379686a2fef33032b8264e72cb787135be0a5a3c26aa452320b309da10ed8a1f8fe6667046 SHA512 ea67fb4d13487d24a0442084f42ff3c082a107c56a06d882f579064f17c545d6e9b5f0c4d724238c22e9b3bad12c68c60c58b59f82d9e957fe3af222d44bc969
DIST bazel-0.20.0-dist.zip 87602213 BLAKE2B 0d10fc89a8bc2bf91a67317d42302b894abbec8c4e9f39dd4fbeae71fcba847d5ae35102e3ef4a26d7dfe2da9e47cec5660dd28e1804c3ad562583e9566b78cb SHA512 1628a99a2c95334b7b190c5cf1b80ad3ce61c827103844f68401ffe5cfa994d5b7edd9e314a2775b6ed5b8da70ad79bee0ef47b9acf409919a613069356623a3
DIST bazel-0.22.0-dist.zip 88633015 BLAKE2B 7cb7ef53c9acb4089b92d82679ad82739fd3c1fd3af7147e13b1474353fdf4cba1f58deed6d1880ec85fe5a07940b8df14af2701361d86e638b5c0e6924300c1 SHA512 b93cd21f0f164c118b90efba761a9492eb9894e24f13ff468defd12b86c7e67f16e51060ac2fc4c2f8dbf51b1c833d41b255fdd8107988e5babf093cfc5b3254
diff --git a/dev-util/bazel/bazel-0.17.2.ebuild b/dev-util/bazel/bazel-0.17.2.ebuild
deleted file mode 100644
index 79fea4a87e0a..000000000000
--- a/dev-util/bazel/bazel-0.17.2.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 java-pkg-2 multiprocessing
-
-DESCRIPTION="Fast and correct automated build system"
-HOMEPAGE="http://bazel.io/"
-
-SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples tools zsh-completion"
-# strip corrupts the bazel binary
-RESTRICT="strip"
-RDEPEND="virtual/jdk:1.8"
-DEPEND="${RDEPEND}
- app-arch/unzip
- app-arch/zip"
-
-S="${WORKDIR}"
-QA_FLAGS_IGNORED="usr/bin/bazel"
-
-bazel-get-flags() {
- local i fs=()
- for i in ${CFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- done
- for i in ${CXXFLAGS}; do
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${CPPFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${LDFLAGS}; do
- fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
- done
- echo "${fs[*]}"
-}
-
-pkg_setup() {
- echo ${PATH} | grep -q ccache && \
- ewarn "${PN} usually fails to compile with ccache, you have been warned"
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- # Only unpack the main distfile
- unpack ${P}-dist.zip
-}
-
-src_prepare() {
- default
-
- sed -i 's@//src:bazel@//src:bazel_nojdk@' scripts/BUILD || die
-
- # F: fopen_wr
- # S: deny
- # P: /proc/self/setgroups
- # A: /proc/self/setgroups
- # R: /proc/24939/setgroups
- # C: /usr/lib/systemd/systemd
- addpredict /proc
-
- # Use standalone strategy to deactivate the bazel sandbox, since it
- # conflicts with FEATURES=sandbox.
- cat > "${T}/bazelrc" <<-EOF
- build --verbose_failures
- build --spawn_strategy=standalone --genrule_strategy=standalone
-
- build --distdir=${S}/derived/distdir/
- build --jobs=$(makeopts_jobs) $(bazel-get-flags)
-
- test --verbose_failures --verbose_test_summary
- test --spawn_strategy=standalone --genrule_strategy=standalone
- EOF
-
- echo "import ${T}/bazelrc" >> "${S}/.bazelrc"
-}
-
-src_compile() {
- export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
- VERBOSE=yes ./compile.sh || die
- output/bazel --bazelrc="${T}/bazelrc" build //scripts:bazel-complete.bash || die
- output/bazel shutdown
-}
-
-src_test() {
- output/bazel test \
- --verbose_failures \
- --spawn_strategy=standalone \
- --genrule_strategy=standalone \
- --verbose_test_summary \
- examples/cpp:hello-success_test || die
- output/bazel shutdown
-}
-
-src_install() {
- dobin output/bazel
- newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
- bashcomp_alias ${PN} ibazel
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins scripts/zsh_completion/_bazel
- fi
-
- if use examples; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
- # could really build tools but I don't know which ones
- # are actually used
- if use tools; then
- docinto tools
- dodoc -r tools/*
- docompress -x /usr/share/doc/${PF}/tools
- fi
-}
diff --git a/dev-util/bazel/bazel-0.18.0.ebuild b/dev-util/bazel/bazel-0.18.0.ebuild
deleted file mode 100644
index c1c992cd2cab..000000000000
--- a/dev-util/bazel/bazel-0.18.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 java-pkg-2 multiprocessing
-
-DESCRIPTION="Fast and correct automated build system"
-HOMEPAGE="http://bazel.io/"
-
-SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples tools zsh-completion"
-# strip corrupts the bazel binary
-RESTRICT="strip"
-RDEPEND="virtual/jdk:1.8"
-DEPEND="${RDEPEND}
- app-arch/unzip
- app-arch/zip"
-
-S="${WORKDIR}"
-QA_FLAGS_IGNORED="usr/bin/bazel"
-
-bazel-get-flags() {
- local i fs=()
- for i in ${CFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- done
- for i in ${CXXFLAGS}; do
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${CPPFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${LDFLAGS}; do
- fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
- done
- echo "${fs[*]}"
-}
-
-pkg_setup() {
- echo ${PATH} | grep -q ccache && \
- ewarn "${PN} usually fails to compile with ccache, you have been warned"
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- # Only unpack the main distfile
- unpack ${P}-dist.zip
-}
-
-src_prepare() {
- default
-
- sed -i 's@//src:bazel@//src:bazel_nojdk@' scripts/BUILD || die
-
- # F: fopen_wr
- # S: deny
- # P: /proc/self/setgroups
- # A: /proc/self/setgroups
- # R: /proc/24939/setgroups
- # C: /usr/lib/systemd/systemd
- addpredict /proc
-
- # Use standalone strategy to deactivate the bazel sandbox, since it
- # conflicts with FEATURES=sandbox.
- cat > "${T}/bazelrc" <<-EOF
- build --verbose_failures
- build --spawn_strategy=standalone --genrule_strategy=standalone
-
- build --distdir=${S}/derived/distdir/
- build --jobs=$(makeopts_jobs) $(bazel-get-flags)
-
- test --verbose_failures --verbose_test_summary
- test --spawn_strategy=standalone --genrule_strategy=standalone
- EOF
-}
-
-src_compile() {
- export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
- VERBOSE=yes ./compile.sh || die
- output/bazel --bazelrc="${T}/bazelrc" build //scripts:bazel-complete.bash || die
- output/bazel shutdown
-}
-
-src_test() {
- output/bazel test \
- --verbose_failures \
- --spawn_strategy=standalone \
- --genrule_strategy=standalone \
- --verbose_test_summary \
- examples/cpp:hello-success_test || die
- output/bazel shutdown
-}
-
-src_install() {
- dobin output/bazel
- newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
- bashcomp_alias ${PN} ibazel
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins scripts/zsh_completion/_bazel
- fi
-
- if use examples; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
- # could really build tools but I don't know which ones
- # are actually used
- if use tools; then
- docinto tools
- dodoc -r tools/*
- docompress -x /usr/share/doc/${PF}/tools
- fi
-}
diff --git a/dev-util/bazel/bazel-0.19.0.ebuild b/dev-util/bazel/bazel-0.19.0.ebuild
deleted file mode 100644
index dda30d679453..000000000000
--- a/dev-util/bazel/bazel-0.19.0.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 java-pkg-2 multiprocessing
-
-DESCRIPTION="Fast and correct automated build system"
-HOMEPAGE="http://bazel.io/"
-
-SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples tools"
-# strip corrupts the bazel binary
-RESTRICT="strip"
-RDEPEND="virtual/jdk:1.8"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}"
-QA_FLAGS_IGNORED="usr/bin/bazel"
-
-bazel-get-flags() {
- local i fs=()
- for i in ${CFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- done
- for i in ${CXXFLAGS}; do
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${CPPFLAGS}; do
- fs+=( "--copt=${i}" "--host_copt=${i}" )
- fs+=( "--cxxopt=${i}" "--host_cxxopt=${i}" )
- done
- for i in ${LDFLAGS}; do
- fs+=( "--linkopt=${i}" "--host_linkopt=${i}" )
- done
- echo "${fs[*]}"
-}
-
-pkg_setup() {
- echo ${PATH} | grep -q ccache && \
- ewarn "${PN} usually fails to compile with ccache, you have been warned"
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- # Only unpack the main distfile
- unpack ${P}-dist.zip
-}
-
-src_prepare() {
- default
-
- sed -i 's@//src:bazel@//src:bazel_nojdk@' scripts/BUILD || die
-
- # F: fopen_wr
- # S: deny
- # P: /proc/self/setgroups
- # A: /proc/self/setgroups
- # R: /proc/24939/setgroups
- # C: /usr/lib/systemd/systemd
- addpredict /proc
-
- # Use standalone strategy to deactivate the bazel sandbox, since it
- # conflicts with FEATURES=sandbox.
- cat > "${T}/bazelrc" <<-EOF
- build --verbose_failures
- build --spawn_strategy=standalone --genrule_strategy=standalone
-
- build --distdir=${S}/derived/distdir/
- build --jobs=$(makeopts_jobs) $(bazel-get-flags)
-
- test --verbose_failures --verbose_test_summary
- test --spawn_strategy=standalone --genrule_strategy=standalone
- EOF
-}
-
-src_compile() {
- export EXTRA_BAZEL_ARGS="--jobs=$(makeopts_jobs)"
- VERBOSE=yes ./compile.sh || die
-
- local OPTS=""
- if [[ $(java-config -g PROVIDES_VERSION) == "1.8" ]]; then
- OPTS="--java_toolchain=@bazel_tools//tools/jdk:toolchain_hostjdk8"
- OPTS+=" --host_java_toolchain=@bazel_tools//tools/jdk:toolchain_hostjdk8"
- fi
-
- output/bazel --bazelrc="${T}/bazelrc" build ${OPTS} //scripts:bazel-complete.bash || die
- output/bazel shutdown
-}
-
-src_test() {
- output/bazel test \
- --verbose_failures \
- --spawn_strategy=standalone \
- --genrule_strategy=standalone \
- --verbose_test_summary \
- examples/cpp:hello-success_test || die
- output/bazel shutdown
-}
-
-src_install() {
- dobin output/bazel
- newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
- bashcomp_alias ${PN} ibazel
- insinto /usr/share/zsh/site-functions
- doins scripts/zsh_completion/_bazel
-
- if use examples; then
- docinto examples
- dodoc -r examples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
- # could really build tools but I don't know which ones
- # are actually used
- if use tools; then
- docinto tools
- dodoc -r tools/*
- docompress -x /usr/share/doc/${PF}/tools
- fi
-}