summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-03-11 20:04:18 -0700
committerZac Medico <zmedico@gentoo.org>2020-03-11 20:06:23 -0700
commit60eed76853ace00c133366799872b2e9611e9485 (patch)
tree612c7d1147c8a27206199f3460a4442e8dd8b363 /dev-util/bcc
parentsys-apps/shadow: depend on >=sys-kernel/linux-headers-4.19 (diff)
downloadgentoo-60eed76853ace00c133366799872b2e9611e9485.tar.gz
gentoo-60eed76853ace00c133366799872b2e9611e9485.tar.bz2
gentoo-60eed76853ace00c133366799872b2e9611e9485.zip
dev-util/bcc: LLVM_MAX_SLOT=9 (bug 711790)
Closes: https://bugs.gentoo.org/711790 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/bcc')
-rw-r--r--dev-util/bcc/bcc-0.13.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-util/bcc/bcc-0.13.0.ebuild b/dev-util/bcc/bcc-0.13.0.ebuild
index 8ff7d3262f47..748cd29f46e9 100644
--- a/dev-util/bcc/bcc-0.13.0.ebuild
+++ b/dev-util/bcc/bcc-0.13.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils linux-info python-single-r1
+inherit cmake-utils linux-info llvm python-single-r1
EGIT_COMMIT="v${PV}"
LIBBPF_VER="0.0.7"
@@ -27,8 +27,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
>=sys-kernel/linux-headers-4.14
>=dev-libs/elfutils-0.166:=
- sys-devel/clang:=
- >=sys-devel/llvm-3.7.1:=[llvm_targets_BPF(+)]
+ <sys-devel/clang-10:=
+ <sys-devel/llvm-10:=[llvm_targets_BPF(+)]
luajit? ( dev-lang/luajit )
${PYTHON_DEPS}
"
@@ -65,6 +65,7 @@ pkg_pretend() {
}
pkg_setup() {
+ LLVM_MAX_SLOT=9 llvm_pkg_setup
python-single-r1_pkg_setup
}