summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2019-09-26 13:45:11 +0100
committerMike Auty <ikelos@gentoo.org>2019-09-26 13:45:11 +0100
commita23eb91242ec8f1232eb4dd7954124aff40b3654 (patch)
treef9cce98c79710fea25676744f0b3d096c35cf7e8 /dev-util/bless/bless-0.6.2-r1.ebuild
parentprofiles: [QA] Package mask x11-libs/libXvMC-1.0.12. (diff)
downloadgentoo-a23eb91242ec8f1232eb4dd7954124aff40b3654.tar.gz
gentoo-a23eb91242ec8f1232eb4dd7954124aff40b3654.tar.bz2
gentoo-a23eb91242ec8f1232eb4dd7954124aff40b3654.zip
dev-util/bless: Bump to improve dependency inaccuracy.
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Mike Auty <ikelos@gentoo.org>
Diffstat (limited to 'dev-util/bless/bless-0.6.2-r1.ebuild')
-rw-r--r--dev-util/bless/bless-0.6.2-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/bless/bless-0.6.2-r1.ebuild b/dev-util/bless/bless-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..06741696a4d9
--- /dev/null
+++ b/dev-util/bless/bless-0.6.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2 mono-env
+
+DESCRIPTION="GTK# Hex Editor"
+HOMEPAGE="https://github.com/afrantzis/Bless/"
+SRC_URI="https://github.com/afrantzis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# EGIT_REPO_URI="https://github.com/afrantzis/bless/"
+# EGIT_COMMIT="v${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ >=dev-lang/mono-1.1.14
+ >=dev-dotnet/gtk-sharp-2.12.21:2
+"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ >=sys-devel/gettext-0.15
+ virtual/pkgconfig
+"
+
+# See bug 278162
+# Waiting on nunit ebuild entering the tree
+RESTRICT="test"
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ eautoreconf
+ # The autoreconf expects INSTALL to have been copied over by autoconf
+ touch "${S}/INSTALL"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-unix-specific \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}" || die "Unable to make documentation version-specific."
+}