summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bless/files/bless-0.6.0-docpath.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bless/files/bless-0.6.0-docpath.patch')
-rw-r--r--dev-util/bless/files/bless-0.6.0-docpath.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/bless/files/bless-0.6.0-docpath.patch b/dev-util/bless/files/bless-0.6.0-docpath.patch
new file mode 100644
index 000000000000..b1121424d88b
--- /dev/null
+++ b/dev-util/bless/files/bless-0.6.0-docpath.patch
@@ -0,0 +1,71 @@
+diff --git a/Makefile.am b/Makefile.am
+index 33f265b..346326d 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,9 @@
+ EXTRA_DIST = AUTHORS COPYING NEWS README README.packaging \
+ bless.mdp bless.mds bless.spec autogen.sh bless.mi
+
++doc_DATA = AUTHORS COPYING INSTALL ChangeLog NEWS \
++ README README.packaging bless.spec
++
+ SUBDIRS = po builder src bin data doc . tests
+
+ DIST_SUBDIRS= po builder src bin doc data tests
+@@ -34,11 +37,5 @@ bless-builder:
+ dist-hook:
+ bzr log > $(distdir)/ChangeLog
+
+-install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+- $(INSTALL_DATA) AUTHORS COPYING INSTALL ChangeLog NEWS \
+- README README.packaging bless.spec \
+- $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+-
+ uninstall-local:
+ rm -rf $(DESTDIR)$(libdir)/$(PACKAGE_NAME)
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index b18e94a..d7eecc6 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,4 +1 @@
+ SUBDIRS= developer user
+-
+-uninstall-local:
+- rm -rf $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)
+diff --git a/doc/user/Makefile.am b/doc/user/Makefile.am
+index 729b295..58a1358 100644
+--- a/doc/user/Makefile.am
++++ b/doc/user/Makefile.am
+@@ -7,6 +7,11 @@ CLEANFILES=$(OMF)
+
+ noinst_SCRIPTS=$(OMF)
+
++docmandir=$(docdir)/user
++docfigsdir=$(docmandir)/figures
++
++docfigs_DATA=$(FIGURES)
++docman_DATA=$(DOCS) $(wildcard *.html)
+
+ $(OMF): $(OMF).in
+ if [ -x `which scrollkeeper-preinstall` ]; then \
+@@ -27,11 +32,6 @@ dist-hook: doc
+ rm html_file_list
+
+ install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user/figures
+- $(INSTALL_DATA) $(DOCS) $(wildcard *.html) \
+- $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+- $(INSTALL_DATA) $(FIGURES) $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user/figures
+ $(INSTALL) -d $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)
+ $(INSTALL_DATA) $(OMF) $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)
+ if WITH_SCROLLKEEPER
+@@ -39,7 +39,6 @@ if WITH_SCROLLKEEPER
+ endif
+
+ uninstall-local:
+- rm -rf $(DESTDIR)$(datadir)/doc/$(PACKAGE_NAME)/user
+ rm $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)/$(OMF)
+ if WITH_SCROLLKEEPER
+ scrollkeeper-update -o $(DESTDIR)$(datadir)/omf/$(PACKAGE_NAME)