summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-07-13 14:07:27 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-07-13 14:07:38 -0700
commitcf1ef9d692a509052c5ef64a6c34bec7000c4bf5 (patch)
treedbb1a7abd8214b392fec0b01335a180275a7c099 /dev-util/bpftrace/files
parentsys-kernel/vanilla-kernel: Remove old (diff)
downloadgentoo-cf1ef9d692a509052c5ef64a6c34bec7000c4bf5.tar.gz
gentoo-cf1ef9d692a509052c5ef64a6c34bec7000c4bf5.tar.bz2
gentoo-cf1ef9d692a509052c5ef64a6c34bec7000c4bf5.zip
dev-util/bpftrace-0.13.0-r1: revbump, install lib (bug #801472)
Closes: https://bugs.gentoo.org/801472 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/bpftrace/files')
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
index 03fd2d13e602..fb75f9db1ba3 100644
--- a/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
+++ b/dev-util/bpftrace/files/bpftrace-0.13.0-install-libs.patch
@@ -52,10 +52,10 @@ index 0361cdaa..f9c536a3 100644
if (LIBBPF_BTF_DUMP_FOUND)
target_include_directories(libbpftrace PUBLIC ${LIBBPF_INCLUDE_DIRS})
diff --git a/src/arch/CMakeLists.txt b/src/arch/CMakeLists.txt
-index 76bb217e..6d243a7e 100644
+index 76bb217e..4ad0f626 100644
--- a/src/arch/CMakeLists.txt
+++ b/src/arch/CMakeLists.txt
-@@ -1,15 +1,15 @@
+@@ -1,15 +1,17 @@
if(CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
- add_library(arch aarch64.cpp)
+ add_library(bpftracearch aarch64.cpp)
@@ -76,6 +76,8 @@ index 76bb217e..6d243a7e 100644
else()
message(FATAL_ERROR "Unsupported architecture: ${CMAKE_SYSTEM_PROCESSOR}")
endif()
++
++install(TARGETS bpftracearch LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/src/ast/CMakeLists.txt b/src/ast/CMakeLists.txt
index 5234388c..8b40faaa 100644
--- a/src/ast/CMakeLists.txt