summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:14 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:38 +0100
commit10f8fc530a1115a751bc4c3756453c8700163947 (patch)
treead254a0965de2f8a44d0ddb55fdc761c7ae23747 /dev-util/bpftrace
parentdev-util/bpftrace: Reorganize deps, bump max llvm version (diff)
downloadgentoo-10f8fc530a1115a751bc4c3756453c8700163947.tar.gz
gentoo-10f8fc530a1115a751bc4c3756453c8700163947.tar.bz2
gentoo-10f8fc530a1115a751bc4c3756453c8700163947.zip
dev-util/bpftrace: Drop live ebuild skeleton
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/bpftrace')
-rw-r--r--dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild22
1 files changed, 6 insertions, 16 deletions
diff --git a/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild b/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
index abc8391c68ea..efe4e68822da 100644
--- a/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
+++ b/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
@@ -7,19 +7,13 @@ inherit toolchain-funcs llvm linux-info cmake
DESCRIPTION="High-level tracing language for eBPF"
HOMEPAGE="https://github.com/iovisor/bpftrace"
-
-if [[ ${PV} =~ 9{4,} ]]; then
- EGIT_REPO_URI="https://github.com/iovisor/${PN}"
- inherit git-r3
-else
- MY_PV="${PV//_/}"
- SRC_URI="https://github.com/iovisor/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND="app-arch/xz-utils "
-fi
+MY_PV="${PV//_/}"
+SRC_URI="https://github.com/iovisor/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV:-${PV}}"
LICENSE="Apache-2.0"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="fuzzing test"
# lots of fixing needed
RESTRICT="test"
@@ -38,12 +32,12 @@ DEPEND="
dev-libs/cereal:=
test? ( dev-cpp/gtest )
"
-BDEPEND+="
+BDEPEND="
+ app-arch/xz-utils
sys-devel/flex
sys-devel/bison
"
-S="${WORKDIR}/${PN}-${MY_PV:-${PV}}"
QA_DT_NEEDED="/usr/lib.*/libbpftraceresources.so"
PATCHES=(
@@ -70,10 +64,6 @@ pkg_setup() {
LLVM_MAX_SLOT=13 llvm_pkg_setup
}
-src_prepare() {
- cmake_src_prepare
-}
-
src_configure() {
local -a mycmakeargs=(
-DSTATIC_LINKING:BOOL=OFF