summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-10-26 15:05:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-10-26 15:07:06 -0700
commit83059a7de54913700cdfe7d36391673c1b7ebcc9 (patch)
treed9e4d23c427129cc1d8bc2443c3b2a89ef55b800 /dev-util/bpftrace
parentmedia-video/obs-studio: remove version 27.1.3 (r0) (diff)
downloadgentoo-83059a7de54913700cdfe7d36391673c1b7ebcc9.tar.gz
gentoo-83059a7de54913700cdfe7d36391673c1b7ebcc9.tar.bz2
gentoo-83059a7de54913700cdfe7d36391673c1b7ebcc9.zip
dev-util/bpftrace: bump fix install of ast lib (bug # 784332)
Closes: https://bugs.gentoo.org/784332 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/bpftrace')
-rw-r--r--dev-util/bpftrace/bpftrace-0.14.0-r1.ebuild (renamed from dev-util/bpftrace/bpftrace-0.14.0.ebuild)0
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.14.0-install-libs.patch9
2 files changed, 5 insertions, 4 deletions
diff --git a/dev-util/bpftrace/bpftrace-0.14.0.ebuild b/dev-util/bpftrace/bpftrace-0.14.0-r1.ebuild
index 483f341c4909..483f341c4909 100644
--- a/dev-util/bpftrace/bpftrace-0.14.0.ebuild
+++ b/dev-util/bpftrace/bpftrace-0.14.0-r1.ebuild
diff --git a/dev-util/bpftrace/files/bpftrace-0.14.0-install-libs.patch b/dev-util/bpftrace/files/bpftrace-0.14.0-install-libs.patch
index 00d35c6f49e7..dc8e89052602 100644
--- a/dev-util/bpftrace/files/bpftrace-0.14.0-install-libs.patch
+++ b/dev-util/bpftrace/files/bpftrace-0.14.0-install-libs.patch
@@ -115,7 +115,7 @@ index 76bb217e..4ad0f626 100644
+
+install(TARGETS bpftracearch LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/src/ast/CMakeLists.txt b/src/ast/CMakeLists.txt
-index 014295cd..b038aa18 100644
+index 014295cd..c35f6ac6 100644
--- a/src/ast/CMakeLists.txt
+++ b/src/ast/CMakeLists.txt
@@ -1,6 +1,6 @@
@@ -126,13 +126,14 @@ index 014295cd..b038aa18 100644
async_event_types.cpp
attachpoint_parser.cpp
int_parser.cpp
-@@ -20,11 +20,12 @@ add_library(ast
+@@ -20,11 +20,13 @@ add_library(ast
target_include_directories(ast_defs PUBLIC ${CMAKE_SOURCE_DIR}/src)
target_include_directories(ast_defs PUBLIC ${CMAKE_SOURCE_DIR}/src/ast)
target_include_directories(ast_defs PUBLIC ${CMAKE_BINARY_DIR})
-target_link_libraries(ast ast_defs arch bpforc parser)
+target_link_libraries(bpftraceast ast_defs bpftracearch bpforc bpftraceparser)
+install(TARGETS ast_defs LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(TARGETS bpftraceast LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
-add_dependencies(ast_defs parser)
+add_dependencies(ast_defs bpftraceparser)
@@ -142,7 +143,7 @@ index 014295cd..b038aa18 100644
if (STATIC_LINKING)
set(clang_libs
-@@ -55,11 +56,11 @@ if (STATIC_LINKING)
+@@ -55,11 +57,11 @@ if (STATIC_LINKING)
if(EMBED_USE_LLVM)
@@ -157,7 +158,7 @@ index 014295cd..b038aa18 100644
endif()
if(STATIC_LIBC)
-@@ -69,13 +70,13 @@ if (STATIC_LINKING)
+@@ -69,13 +71,13 @@ if (STATIC_LINKING)
else()
find_library(found_LLVM LLVM HINTS ${LLVM_LIBRARY_DIRS})
if(found_LLVM)