summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:17 +0100
committerJakov Smolić <jsmolic@gentoo.org>2021-11-07 21:58:40 +0100
commit9af1ceff0ce358bd93f2e54e8f4a7ef496623d45 (patch)
tree14060eed56890b11b0d4cd05a8731589a62ee904 /dev-util/bpftrace
parentdev-util/bpftrace: Statically link (partially), avoid stripping bpftrace (diff)
downloadgentoo-9af1ceff0ce358bd93f2e54e8f4a7ef496623d45.tar.gz
gentoo-9af1ceff0ce358bd93f2e54e8f4a7ef496623d45.tar.bz2
gentoo-9af1ceff0ce358bd93f2e54e8f4a7ef496623d45.zip
dev-util/bpftrace: Fix includes in fuzz_main.cpp
Closes: https://bugs.gentoo.org/801385 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/bpftrace')
-rw-r--r--dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild1
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.14.0-fuzzing.patch18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild b/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
index 4435e4c83795..9f4a31fdf7bc 100644
--- a/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
+++ b/dev-util/bpftrace/bpftrace-0.14.0-r3.ebuild
@@ -43,6 +43,7 @@ QA_DT_NEEDED="/usr/lib.*/libbpftraceresources.so"
PATCHES=(
"${FILESDIR}/bpftrace-0.14.0-install-libs.patch"
"${FILESDIR}/bpftrace-0.14.0-dont-compress-man.patch"
+ "${FILESDIR}/bpftrace-0.14.0-fuzzing.patch"
"${FILESDIR}/bpftrace-0.11.4-old-kernels.patch"
"${FILESDIR}/bpftrace-0.12.0-fuzzing-build.patch"
)
diff --git a/dev-util/bpftrace/files/bpftrace-0.14.0-fuzzing.patch b/dev-util/bpftrace/files/bpftrace-0.14.0-fuzzing.patch
new file mode 100644
index 000000000000..6c759a9e1ca1
--- /dev/null
+++ b/dev-util/bpftrace/files/bpftrace-0.14.0-fuzzing.patch
@@ -0,0 +1,18 @@
+https://github.com/iovisor/bpftrace/pull/2059
+--- a/src/fuzz_main.cpp
++++ b/src/fuzz_main.cpp
+@@ -17,12 +17,12 @@
+ #include <unistd.h>
+
+ #include "ast/bpforc/bpforc.h"
+-#include "ast/clang_parser.h"
++#include "clang_parser.h"
+ #include "ast/passes/callback_visitor.h"
+ #include "ast/passes/field_analyser.h"
+ #include "ast/passes/semantic_analyser.h"
+ #include "bpftrace.h"
+-#include "codegen_llvm.h"
++#include "ast/passes/codegen_llvm.h"
+ #include "driver.h"
+ #include "log.h"
+ #include "output.h"