summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-01-17 12:36:07 -0500
committerBrian Dolbec <dolsen@gentoo.org>2021-01-17 13:45:29 -0500
commitd53142a227be03c4d7225cdaca12cd876883addc (patch)
treee91d2d9ffb1f10756cc994fa89188fd0dc07b47a /dev-util/buildbot-console-view
parentdev-util/buildbot-waterfall-view: Version bump to 2.10.0 fix setuptools ?depend (diff)
downloadgentoo-d53142a227be03c4d7225cdaca12cd876883addc.tar.gz
gentoo-d53142a227be03c4d7225cdaca12cd876883addc.tar.bz2
gentoo-d53142a227be03c4d7225cdaca12cd876883addc.zip
dev-util/buildbot-console-view: Version bump to 2.10.0 fix setuptools ?depend
Closes: https://bugs.gentoo.org/747733 Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-2.10.0.ebuild37
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild4
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-2.8.4.ebuild4
4 files changed, 42 insertions, 4 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index ed1412ff4846..4264458d1645 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -1,2 +1,3 @@
+DIST buildbot-console-view-2.10.0.tar.gz 18720 BLAKE2B 00ae39bbd4ec9ee13dea161e4ee853fc65ed61c5aef11ece5766c2ca17db292fedf8c636726c5616c7e2f76edbe6c0c9e2cd442da3d52311857c13947dc6f9b1 SHA512 cb1899179e14df9076224d33d8a0364cde4c74825c5ba1c281dabb1cdab976c7eb4fcb8a1e73274a3198d36b8e24a85e4736dde1ae8f42244e4001a340536785
DIST buildbot-console-view-2.8.2.tar.gz 17575 BLAKE2B e036429dd40fdfdadd65a10d4f6fc025b00d9a61153aecd4f31e0c6c133ba1e546b1c810254ec1fb83913cd4434db223c3cd782481ef5785ec48162a2f111682 SHA512 dbec358933865aa79ad86754ef454d89fa369fc64f3df54eb079c0f1ebadb027131d4bd7ac14dd29a16d34aa416e21f90cbecc873944a7ab8ef7da637e20c999
DIST buildbot-console-view-2.8.4.tar.gz 18531 BLAKE2B 8d997e34eefea4be6bbbb33902b992a4864b601ef689cedbd7051667e5cab1ee45b13e2d5ad888af4a805ab1a60f0bc79439580583b3c3e233d321b52b28e0d9 SHA512 ccaa8b9ab18bd6e6609ab017ce4f2d447f99310b3448584decb8a572c573426bf84e6b86837f68b715863c66de013a8cad546e35dbbfb051c1c8d32a3825fe7f
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-2.10.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-2.10.0.ebuild
new file mode 100644
index 000000000000..1fe0ebf129ac
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-2.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild
index 461db8d8fd20..1fe0ebf129ac 100644
--- a/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild
+++ b/dev-util/buildbot-console-view/buildbot-console-view-2.8.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-2.8.4.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-2.8.4.ebuild
index 461db8d8fd20..1fe0ebf129ac 100644
--- a/dev-util/buildbot-console-view/buildbot-console-view-2.8.4.ebuild
+++ b/dev-util/buildbot-console-view/buildbot-console-view-2.8.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1