summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-06-20 10:30:16 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-06-20 12:04:30 -0400
commite822c5f528ce0ff746d53867c25c5995be837217 (patch)
treeb7fffe81714ff7318f54205ee4ff99e154168e0b /dev-util/buildbot-console-view
parentdev-util/buildbot: Version bump to 3.2.0 (diff)
downloadgentoo-e822c5f528ce0ff746d53867c25c5995be837217.tar.gz
gentoo-e822c5f528ce0ff746d53867c25c5995be837217.tar.bz2
gentoo-e822c5f528ce0ff746d53867c25c5995be837217.zip
dev-util/buildbot-console-view: Version bump to 3.2.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-console-view')
-rw-r--r--dev-util/buildbot-console-view/Manifest1
-rw-r--r--dev-util/buildbot-console-view/buildbot-console-view-3.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/buildbot-console-view/Manifest b/dev-util/buildbot-console-view/Manifest
index 20e060d79698..e058db0cb12a 100644
--- a/dev-util/buildbot-console-view/Manifest
+++ b/dev-util/buildbot-console-view/Manifest
@@ -5,3 +5,4 @@ DIST buildbot-console-view-2.8.4.tar.gz 18531 BLAKE2B 8d997e34eefea4be6bbbb33902
DIST buildbot-console-view-3.0.2.tar.gz 18724 BLAKE2B bc8a75ba284547c5d9c71094f0780242198be14d0e86da2ee837c3437e8e4c76212d4c8ebafb9e6042a8fc8a35530e6fa0df95890ab6fe592d295de2b74df1ba SHA512 15e80c4036c5451a1a48d2d7254118586c4a97ea49d06d04a1237f1c82bdf8b3c044235c7b1cfa46cf892168e94becd48cd4d376479abd8212dbfc0662b7cecc
DIST buildbot-console-view-3.1.0.tar.gz 18730 BLAKE2B 61703292ddff90e096cd70a5f1001d0e521884f1e89936ca0f11c917867224ac60d61fe96a6f24a51cdfd4b40bb052443a839a51a8849cb76bb93b938a0272c9 SHA512 88b568ec2a7457b074e7448671991e907d52bcf5b1298d37f6b567b9e5ffc98b82ee1f0d9aed3a5841904d482476502f88aca31b93e505b5ea8db56d8b8f882f
DIST buildbot-console-view-3.1.1.tar.gz 18731 BLAKE2B 266e08a04f5c6e618c101d5c7fcfaf08b7ad389346bce94f5e6e2a9cc3eb65906228c0ad12503a0ef1beb330b2f16ff3a532ac9861443018b7a5eb4c85488d64 SHA512 6287643f320a06bd56b8826fbca665a5a2d5bc0914c0dfd7b01fe273ce3220fd89a0267ed4bed979393b87d5a48fa53df579acc4df965be12f87eab43584eae5
+DIST buildbot-console-view-3.2.0.tar.gz 18732 BLAKE2B e9629d9aac9534c5948732dd94a0cda9da77c391bb0748e06c6d8ef04540e6a09af709db2f0096c74d3b942e02733938913be2cdcf121812526ac299f59b2573 SHA512 478e2273660e8af1d0f2ec61d5197819ae71db23e1319ef7f7d3aaa99ab2023c954dd917bcb4eed3b92da5a13b174cf31e28408dc6cc64bd2284a87dcb0cecc2
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-3.2.0.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-3.2.0.ebuild
new file mode 100644
index 000000000000..251b0b05b8c9
--- /dev/null
+++ b/dev-util/buildbot-console-view/buildbot-console-view-3.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-console-view/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+}