summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-02-01 16:10:14 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-02-01 16:22:52 -0800
commit6cb30aa05a58202a8fca9803d6172bcee7d67d49 (patch)
tree5653d57f6b77fbaff2dddbcd8eac5ea1b8782b03 /dev-util/buildbot-pkg
parentdev-util/buildbot: Re-add the 0.9.0_p1 release due to a regression in newer v... (diff)
downloadgentoo-6cb30aa05a58202a8fca9803d6172bcee7d67d49.tar.gz
gentoo-6cb30aa05a58202a8fca9803d6172bcee7d67d49.tar.bz2
gentoo-6cb30aa05a58202a8fca9803d6172bcee7d67d49.zip
dev-util/buildbot-pkg: Re-add the 0.9.0_p1 release due to a regression in newer versions
Package-Manager: Portage-2.3.3_p38, Repoman-2.3.1_p31
Diffstat (limited to 'dev-util/buildbot-pkg')
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-0.9.0_p1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index 38f44d1b2e17..7e3d80869701 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -1,3 +1,4 @@
+DIST buildbot-pkg-0.9.0.post1.tar.gz 3369 SHA256 7149d8f4d906914b77375855c3de30ec2c9edb26f5da6c654dcceb360eb3353b SHA512 decef481958f4f85797260e00a501a55e6c8f0b3938ca9d8b98f773481a7484f221ceb5eb4e45ed7efc32e88bb16a4431ae0c2e7a8203c384915beea2f32f295 WHIRLPOOL d33a88b2c8ee8f21a62d46eaa8099fb3b579ba9c1c21cbf1cdc8569840cf66f4b8415c7a662344d3a2e472947984bb248c81e761df73d8aa2bb8ee471bc5e8d7
DIST buildbot-pkg-0.9.1.tar.gz 3800 SHA256 6dab917d6bc689fef1c6bc30d6af041ce4fc56c3dacd0378957c3d606094f3a3 SHA512 28b644c64a38d53305c6955a45596c6a27f988363a0d0bd980922842f3d6712b6ee35d74f7124eae5269b95c8755eb4922546d1ea9237b93f8694f4993baa1e8 WHIRLPOOL 09fed25389b43f2688db2e60b0ea7ad73fabd5acca893f2ed958214ccc5449373e950bacc297e403560ae0cabf9f588dae63763e3d8204b955d0705ecc6f2230
DIST buildbot-pkg-0.9.2.tar.gz 3803 SHA256 7c9c8e0e9c85d129e2147c596588df81f29aec72411b7284a57ebb7cfdba1a6e SHA512 b64f48fe2fe645282856ac5e720490cdb9af7b0a4763eeeb95777d652d46b8cb5f2b904b8c109ab6bc18a3f9fb01292a3ddc106ef1e89b84059c7ec025bcdda6 WHIRLPOOL 58765b2ef28d774d7b862f240017fe90ca1f519fee61e3f33045569418777c6ffe2c48f1bea0affb7b60846c1b139856857bce10b09ce23416dc6be33c8f03ed
DIST buildbot-pkg-0.9.3.tar.gz 3799 SHA256 d240d342be4ca01c4597bda039133af8db713ba7b7c2104718d0c357374b2409 SHA512 64fbcd8afee051afe9b76afec63eb463cf7cd2c89c320dafca2f024923a1dbc49fd67dd9f514d8108b85990ca2981be36ed650fcf37486c7b909bd1329efd832 WHIRLPOOL 2bb200ba9b703cec056f3fc1e92130881164193e46a170315bca84b0fac8d743a40e12b0005764b0517133bee973059ce5731a0eb1d5343c28a5bc20556365b1
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_p1.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_p1.ebuild
new file mode 100644
index 000000000000..3fe2ccaa0183
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-0.9.0_p1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+MY_V="0.9.0.post1"
+MY_P="${PN}-${MY_V}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}