summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-04 23:36:34 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-05 16:48:15 -0800
commit1678cf142eb81dd59e5892f3ab8557c78b0670ee (patch)
tree59b250a62d7327a4fbca4eeeadc6d3c61ec3aa9e /dev-util/buildbot-worker/buildbot-worker-9999.ebuild
parentdev-util/buildbot-waterfall-view: Version bump (diff)
downloadgentoo-1678cf142eb81dd59e5892f3ab8557c78b0670ee.tar.gz
gentoo-1678cf142eb81dd59e5892f3ab8557c78b0670ee.tar.bz2
gentoo-1678cf142eb81dd59e5892f3ab8557c78b0670ee.zip
dev-util/buildbot-worker: Version bump, update 9999
This version now enables full test suite operation. Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-util/buildbot-worker/buildbot-worker-9999.ebuild')
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-9999.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
index 1c363daa1e44..99a27e885c04 100644
--- a/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
+++ b/dev-util/buildbot-worker/buildbot-worker-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,8 +13,7 @@ inherit readme.gentoo user distutils-r1
DESCRIPTION="BuildBot Slave Daemon"
HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
-MY_PV="${PV/_p/p}"
-MY_V="0.9.0rc1"
+MY_V="${PV/_p/p}"
MY_P="${PN}-${MY_V}"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
@@ -28,13 +27,18 @@ fi
IUSE="test"
RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
- || ( >=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
- <dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
)
dev-python/future[${PYTHON_USEDEP}]
- !<dev-util/buildbot-0.9.0_rc1"
+ !<dev-util/buildbot-0.9.0_rc1
+"
DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/setuptools_trial[${PYTHON_USEDEP}]
+ )
+"
S="${WORKDIR}/${MY_P}"
[[ ${PV} == *9999 ]] && S=${S}/slave
@@ -51,6 +55,12 @@ pkg_setup() {
build worker, just copy the scripts."
}
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
python_install_all() {
distutils-r1_python_install_all