summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-02-01 16:14:56 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-02-01 16:22:54 -0800
commit6b6c68dcf42f70b3128b74bf5d96af081e73f93f (patch)
tree92d746e6df1f80d7dfdf5102bc8e23142b04936a /dev-util/buildbot-worker
parentdev-util/buildbot-waterfall-view: Re-add the 0.9.0_p1 release due to a regres... (diff)
downloadgentoo-6b6c68dcf42f70b3128b74bf5d96af081e73f93f.tar.gz
gentoo-6b6c68dcf42f70b3128b74bf5d96af081e73f93f.tar.bz2
gentoo-6b6c68dcf42f70b3128b74bf5d96af081e73f93f.zip
dev-util/buildbot-worker: Re-add the 0.9.0_p1 release due to a regression in newer versions
Package-Manager: Portage-2.3.3_p38, Repoman-2.3.1_p31
Diffstat (limited to 'dev-util/buildbot-worker')
-rw-r--r--dev-util/buildbot-worker/Manifest1
-rw-r--r--dev-util/buildbot-worker/buildbot-worker-0.9.0_p1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/buildbot-worker/Manifest b/dev-util/buildbot-worker/Manifest
index 6bed4dfdcbec..428234ffb25e 100644
--- a/dev-util/buildbot-worker/Manifest
+++ b/dev-util/buildbot-worker/Manifest
@@ -1,3 +1,4 @@
+DIST buildbot-worker-0.9.0.post1.tar.gz 95780 SHA256 9da22fdf23462680a37d3995cde75410f204d3cb417491363e3f6561fc9011b9 SHA512 50eb98ad4f870f15b1cc34113db139b3b290bef377b4f66ac7c023590f277c102b8776e3a009f296209cf524377c10f60435b18f47cc39d6c27af04778d3296e WHIRLPOOL 1dd5d4274281fe4f582b5e7b83a99693c41282cb2a5262b8899319d3a1e95888417174b8db4ed9f8dcd52ee66785adac98f0d2ecc8abc158a661dfdfa6cd33da
DIST buildbot-worker-0.9.1.tar.gz 65852 SHA256 1d8ec4fd51e7a3a7dd4de7c512b282c221951cbacc6b2eaf15a157f371a0e902 SHA512 cf5749c6fd67fb72cd7043392efb502608cd2d11374cd43af351904a1b4e82d790338e5f745b47465b5cbf9501d2454d983648a70246c6ae55603ba51261a0d0 WHIRLPOOL e576879f141688e3f79e3cf746491bcc106cb4851f14d4960b10be45b7b01c33c6850fb856d6f083d8510ff78f73016e11250e9ef8864e33bace1834c315dafc
DIST buildbot-worker-0.9.2.tar.gz 66043 SHA256 3d05791ac0c556e3e4fe0ef78911ce47eab4fcbb0b5a51a436234ba49b9c236e SHA512 146c2f2b0c44f5c349459edbe61b448e88f9e42eb1c3b7769a0a07260533e4ad40d2d7bc3df2ebecd355d636834108debe8c2d165a9cdc6d849a537cf5743cc4 WHIRLPOOL f786c3a7ac486a2421877082da08a73079b7655ec0941a9509663983c03874bc8b5c12cb990628d0684db757d493528fab9ea3d99d09c22f2d2bbf606c69d0b5
DIST buildbot-worker-0.9.3.tar.gz 98622 SHA256 57b319a34d0118933e7b2488ee29732bc78c55be978fe34a90ef30f208b8d39c SHA512 a0b6b441eeb71e322a5009d6aa0049cbddc4bd4fc78c14cfd362f80d35385b3ffcf5546614b5920c7cdd574df195f5c510b4acdb925c37ad7e6823f7ab62df33 WHIRLPOOL c349bf7ed402fb90318f89135005976b0dbb8c8fc57679b1d5958ce0fdc52fc7f006aeccc9a3119cdd8c66912a8e6fd7e079471461181effd17d75ce9b16ddba
diff --git a/dev-util/buildbot-worker/buildbot-worker-0.9.0_p1.ebuild b/dev-util/buildbot-worker/buildbot-worker-0.9.0_p1.ebuild
new file mode 100644
index 000000000000..7d8e88bd8a83
--- /dev/null
+++ b/dev-util/buildbot-worker/buildbot-worker-0.9.0_p1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit readme.gentoo user distutils-r1
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_V="0.9.0.post1"
+MY_P="${PN}-${MY_V}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ || ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
+ )
+ dev-python/future[${PYTHON_USEDEP}]
+ !<dev-util/buildbot-0.9.0_rc1"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+[[ ${PV} == *9999 ]] && S=${S}/slave
+
+pkg_setup() {
+ enewuser buildbot
+
+ DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
+ to support starting buildbot_worker through Gentoo's init system. To use this,
+ set up your build worker following the documentation, make sure the
+ resulting directories are owned by the \"buildbot\" user and point
+ \"${ROOT}etc/conf.d/buildbot_worker\" at the right location. The scripts can
+ run as a different user if desired. If you need to run more than one
+ build worker, just copy the scripts."
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/buildbot-worker.1
+
+ newconfd "${FILESDIR}/buildbot_worker.confd" buildbot_worker
+ newinitd "${FILESDIR}/buildbot_worker.initd" buildbot_worker
+ systemd_dounit "${FILESDIR}/buildbot_worker.service"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}