summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/bunny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/bunny')
-rw-r--r--dev-util/bunny/Manifest1
-rw-r--r--dev-util/bunny/bunny-0.93-r1.ebuild41
-rw-r--r--dev-util/bunny/metadata.xml10
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/bunny/Manifest b/dev-util/bunny/Manifest
new file mode 100644
index 000000000000..025e2bb55e78
--- /dev/null
+++ b/dev-util/bunny/Manifest
@@ -0,0 +1 @@
+DIST bunny-0.93.tgz 64575 SHA256 30c7765b960b131246bfe8c25b79d20eae49f282dd0ac3b7e1e293233a446f99 SHA512 275eadd58e75b6bc626cc599447b723ff062281f93c7d98159abf6a65ae70d3588435c514ee809dd19e013d8299ec9f9cdfee776ff03ec6c0478b02752d45392 WHIRLPOOL 6a7f314b84cd91daee5859cb41ee9d0b78692c8b5757f8c283ccaaaaf3c702504c9c670e1eba227581701e0967b42cf0cc48d6982b4ea546e1d65e723b9f197c
diff --git a/dev-util/bunny/bunny-0.93-r1.ebuild b/dev-util/bunny/bunny-0.93-r1.ebuild
new file mode 100644
index 000000000000..18206258ccbf
--- /dev/null
+++ b/dev-util/bunny/bunny-0.93-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small general purpose fuzzer for C programs"
+HOMEPAGE="http://code.google.com/p/bunny-the-fuzzer"
+SRC_URI="http://bunny-the-fuzzer.googlecode.com/files/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i Makefile -e '/ -o /s|$(CFLAGS)|& $(LDFLAGS)|' || die "sed Makefile"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake test1 || die "emake test1 failed"
+ emake test2 || die "emake test2 failed"
+ emake test3 || die "emake test3 failed"
+}
+
+src_install() {
+ dobin ${PN}-{exec,flow,gcc,main,trace} || die "dobin failed"
+ dodoc CHANGES README
+}
diff --git a/dev-util/bunny/metadata.xml b/dev-util/bunny/metadata.xml
new file mode 100644
index 000000000000..511841d32339
--- /dev/null
+++ b/dev-util/bunny/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">bunny-the-fuzzer</remote-id>
+ </upstream>
+</pkgmetadata>