summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-01-15 21:54:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-01-15 22:11:35 +0000
commit46e0a674839ad03bf82cf6f5af270439e15e3004 (patch)
tree52ade27fc4de79358bac9fd3b5e12f919f2186e1 /dev-util/ccache
parentnet-libs/zeromq: x86 stable (bug #675376) (diff)
downloadgentoo-46e0a674839ad03bf82cf6f5af270439e15e3004.tar.gz
gentoo-46e0a674839ad03bf82cf6f5af270439e15e3004.tar.bz2
gentoo-46e0a674839ad03bf82cf6f5af270439e15e3004.zip
dev-util/ccache: bump up to 3.6
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.6.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index a317bc0c7bb3..90c9e12b9d0a 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -2,3 +2,4 @@ DIST ccache-3.2.4.tar.xz 302548 BLAKE2B 7d642dc3f944183660e79cfdfd68948528aa3ea4
DIST ccache-3.3.4.tar.xz 314468 BLAKE2B 6e465598df428979a2c821a698afef25c05d09045cbb54ec54cc3b65b8ce6416b6eb46fae0cf5d60f766129cef11eb01410b522318c67416fdf47f6e8fceae66 SHA512 891bcf11b27fa20a250bc86d182663e46af450a3a807b6cab502f202cd57123ce93bcb1fe5e48866feecda76912a5f742efa5869df9117d81624ba185dd4e02c
DIST ccache-3.5.1a.tar.xz 335888 BLAKE2B 66c044b39dd42c91327e02528a4d6c917ac012c2d08190f7dbc2029ed6d1525aa3a6262fb7528f1721cec510306baa59b498a5afbcf955bb6aaf13594c00d178 SHA512 8a2e9eb06ba21fcf92084afd94fc221168693de545e0448f4da2098bef2bcbfdb017117c325b0bab4931b9e346dd8c1a9d1ebaed0cdc36496d9452985cdd1b43
DIST ccache-3.5.tar.xz 334668 BLAKE2B e3e2b63e8c4c8074514fb3a5794325fa05a4d52f48fc436ab0ad21b643ca4d1a1502c989cb47ed68972b105d4f1642e4fadc5ecef1235fe2bd3be5d218094a79 SHA512 92181fb794f06dc231baa4193c37e8f1d844c9281fd64bcb8f4b35c87b4a88dfc9bf36b810b37151ee85699778fcd3783818949a7010e619aeca7e3b33b7a2e3
+DIST ccache-3.6.tar.xz 340608 BLAKE2B fa92180f53612f84b71c68da4acccefee129e5bfc9b269caa45a9c16219ed835ccf034d61ff938a54f3673fa23410d960475cc37cf5d27d7be641e7518a43f0a SHA512 13ce4c9084983ce77617cf005235987715cd6b630dac13a17cb9badce24aab71bff505e63da4206878e32d337cc674f05fbf78540711ec5b33a0b8384c47fa0d
diff --git a/dev-util/ccache/ccache-3.6.ebuild b/dev-util/ccache/ccache-3.6.ebuild
new file mode 100644
index 000000000000..105a8bada3e6
--- /dev/null
+++ b/dev-util/ccache/ccache-3.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.samba.org/"
+SRC_URI="https://www.samba.org/ftp/ccache/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-size-on-disk.patch #456178
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+)
+
+src_prepare() {
+ default
+
+ # make sure we always use system zlib
+ rm -rf src/zlib || die
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<'/usr/lib/ccache/bin'
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+ readme.gentoo_print_elog
+}