summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-02 23:39:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-02 23:40:01 +0000
commitce56476566e14b4d21c3ce07de83308f6433ecc7 (patch)
treea55350d6b1426c06082a11ff960b700b3f9a8db3 /dev-util/ccache
parentdev-libs/elfutils: disable unstable biarch test (diff)
downloadgentoo-ce56476566e14b4d21c3ce07de83308f6433ecc7.tar.gz
gentoo-ce56476566e14b4d21c3ce07de83308f6433ecc7.tar.bz2
gentoo-ce56476566e14b4d21c3ce07de83308f6433ecc7.zip
dev-util/ccache: disable size cleanup test, bug #649440
Disable "Forced cache cleanup, size limit" test as it relies on stable block size of filesystem where tests are performed. Assumption does not hold true for ecryptfs and btrfs. Disable test. Reported-by: Michał Górny Closes: https://bugs.gentoo.org/649440 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ccache-3.6.ebuild1
-rw-r--r--dev-util/ccache/files/ccache-3.6-disable-sized-cleanup.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/ccache/ccache-3.6.ebuild b/dev-util/ccache/ccache-3.6.ebuild
index 105a8bada3e6..c5335c505f37 100644
--- a/dev-util/ccache/ccache-3.6.ebuild
+++ b/dev-util/ccache/ccache-3.6.ebuild
@@ -23,6 +23,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-3.4-size-on-disk.patch #456178
"${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+ "${FILESDIR}"/${PN}-3.6-disable-sized-cleanup.patch #649440
)
src_prepare() {
diff --git a/dev-util/ccache/files/ccache-3.6-disable-sized-cleanup.patch b/dev-util/ccache/files/ccache-3.6-disable-sized-cleanup.patch
new file mode 100644
index 000000000000..2b12542d26f7
--- /dev/null
+++ b/dev-util/ccache/files/ccache-3.6-disable-sized-cleanup.patch
@@ -0,0 +1,25 @@
+https://bugs.gentoo.org/649440
+
+Disable cleanup based on free filesystem size.
+
+--- a/test/suites/cleanup.bash
++++ b/test/suites/cleanup.bash
+@@ -75,6 +75,9 @@ SUITE_cleanup() {
+ done
+
+ # -------------------------------------------------------------------------
++# Disable test in Gentoo as we don't control temporary filesystem:
++# https://bugs.gentoo.org/649440
++if false; then
+ TEST "Forced cache cleanup, size limit"
+
+ # NOTE: This test is known to fail on filesystems that have unusual block
+@@ -101,7 +104,7 @@ SUITE_cleanup() {
+ file=$CCACHE_DIR/a/result$i-4017.o
+ expect_file_exists $file
+ done
+-
++fi
+ # -------------------------------------------------------------------------
+ TEST "Automatic cache cleanup, limit_multiple 0.9"
+