summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-01-03 18:43:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-01-03 18:45:05 +0000
commitd312d6ee5684543057c01f6880d5cf85d7c04c9b (patch)
tree0b49fa416cdb26272ff1eca7288a98149ce2f777 /dev-util/ccache
parentsys-devel/clang: Backport atomic detection fix (diff)
downloadgentoo-d312d6ee5684543057c01f6880d5cf85d7c04c9b.tar.gz
gentoo-d312d6ee5684543057c01f6880d5cf85d7c04c9b.tar.bz2
gentoo-d312d6ee5684543057c01f6880d5cf85d7c04c9b.zip
dev-util/ccache: bump up to 3.5.1
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/Manifest1
-rw-r--r--dev-util/ccache/ccache-3.5.1.ebuild84
-rw-r--r--dev-util/ccache/files/ccache-3.5.1-configure.patch19
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index bcff8ea031fc..fd20b0190a13 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -1,4 +1,5 @@
DIST ccache-3.2.4.tar.xz 302548 BLAKE2B 7d642dc3f944183660e79cfdfd68948528aa3ea4ef8162a4d04837c85ccace35107e663ec81a15438dab133fca2e8bf100fecd483f33c9b0aa52c68989ae8122 SHA512 d048b70804c81dece97f3ba511b3c109ec0d14e7dca69bc68faeeb61a4a7b5639c03e3e5ad7dad4e42b4bd198d7a7fffa4e3b7ef99590dfd4df0805db6c25db7
DIST ccache-3.3.4.tar.xz 314468 BLAKE2B 6e465598df428979a2c821a698afef25c05d09045cbb54ec54cc3b65b8ce6416b6eb46fae0cf5d60f766129cef11eb01410b522318c67416fdf47f6e8fceae66 SHA512 891bcf11b27fa20a250bc86d182663e46af450a3a807b6cab502f202cd57123ce93bcb1fe5e48866feecda76912a5f742efa5869df9117d81624ba185dd4e02c
DIST ccache-3.4.3.tar.xz 328824 BLAKE2B f2ff3276cbadde642a362400b32291f59f60c274861c4c706f0bced801aec7aeeafeeb611331bc23e96fc8790a1d1ffd39df58f24f6a5384d8ddda0da54c9339 SHA512 8a92ef3f3b3688bb4c0b39106bea387ec3065a074327c1fa793e511192acd5cf9aeb5c0065ee8868a944ec63463c2b59fb84edd952102468cd12fcbb1ee16c49
+DIST ccache-3.5.1.tar.xz 335988 BLAKE2B f9cb8d48b16ebf48a409af6e69f16606e543144781b9988f25f5031dd7c4137709e32f76f6ae8879aef425064e6dce112195849008f2dcc9b6deb39d2726cae5 SHA512 25956ac68f24b3a443d9cf74fe759d9d5946e2f2188d40538a31d383550c6674c22f7e9290ceb71f1ee3987ed8f2802343a5a137b2f68692008ead3a347761af
DIST ccache-3.5.tar.xz 334668 BLAKE2B e3e2b63e8c4c8074514fb3a5794325fa05a4d52f48fc436ab0ad21b643ca4d1a1502c989cb47ed68972b105d4f1642e4fadc5ecef1235fe2bd3be5d218094a79 SHA512 92181fb794f06dc231baa4193c37e8f1d844c9281fd64bcb8f4b35c87b4a88dfc9bf36b810b37151ee85699778fcd3783818949a7010e619aeca7e3b33b7a2e3
diff --git a/dev-util/ccache/ccache-3.5.1.ebuild b/dev-util/ccache/ccache-3.5.1.ebuild
new file mode 100644
index 000000000000..b57ecc61aab5
--- /dev/null
+++ b/dev-util/ccache/ccache-3.5.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.samba.org/"
+SRC_URI="https://www.samba.org/ftp/ccache/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-util/shadowman
+ sys-apps/gentoo-functions"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.4-size-on-disk.patch #456178
+ "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+ "${FILESDIR}"/${PN}-3.5.1-configure.patch
+)
+
+src_prepare() {
+ default
+
+ # make sure we always use system zlib
+ rm -rf src/zlib || die
+ sed \
+ -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+ "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_test() {
+ emake check V=1
+}
+
+src_install() {
+ DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+ default
+
+ dobin ccache-config
+ insinto /usr/share/shadowman/tools
+ newins - ccache <<<'/usr/lib/ccache/bin'
+
+ DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+${EPREFIX}/usr/lib/ccache/bin to the beginning of your path, before ${EPREFIX}/usr/bin.
+Portage 2.0.46-r11+ will automatically take advantage of ccache with
+no additional steps. If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+ readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+ eselect compiler-shadow remove ccache
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT:-/} == / ]]; then
+ eselect compiler-shadow update ccache
+ fi
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+ readme.gentoo_print_elog
+}
diff --git a/dev-util/ccache/files/ccache-3.5.1-configure.patch b/dev-util/ccache/files/ccache-3.5.1-configure.patch
new file mode 100644
index 000000000000..b3e1a29670af
--- /dev/null
+++ b/dev-util/ccache/files/ccache-3.5.1-configure.patch
@@ -0,0 +1,19 @@
+https://github.com/ccache/ccache/issues/344
+
+--- a/configure
++++ b/configure
+@@ -642,4 +642,5 @@ no_implicit_fallthrough_warning
+ more_warnings
+ include_dev_mk
++getopt_long_c
+ extra_libs
+ disable_man
+@@ -4724,4 +4725,8 @@ done
+
+
++if test x"$ac_cv_func_getopt_long" != x"yes"; then
++ getopt_long_c="src/getopt_long.c"
++fi
++
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for compar_fn_t in stdlib.h" >&5
+ $as_echo_n "checking for compar_fn_t in stdlib.h... " >&6; }