summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 15:45:37 +0100
committerSam James <sam@gentoo.org>2022-07-10 16:45:24 +0100
commit8e01b19cc3c9f35fd42d67425eb2f50dc7cddde3 (patch)
treeb0bec78f61aaca1d180fc601f69eaf18ba9969ee /dev-util/cccc
parentdev-libs/libsigsegv: drop 2.12-r1 (diff)
downloadgentoo-8e01b19cc3c9f35fd42d67425eb2f50dc7cddde3.tar.gz
gentoo-8e01b19cc3c9f35fd42d67425eb2f50dc7cddde3.tar.bz2
gentoo-8e01b19cc3c9f35fd42d67425eb2f50dc7cddde3.zip
dev-util/cccc: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cccc')
-rw-r--r--dev-util/cccc/cccc-3.1.6-r1.ebuild (renamed from dev-util/cccc/cccc-3.1.6.ebuild)13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-util/cccc/cccc-3.1.6.ebuild b/dev-util/cccc/cccc-3.1.6-r1.ebuild
index 07e35cae7b41..17d9b4e8f1b9 100644
--- a/dev-util/cccc/cccc-3.1.6.ebuild
+++ b/dev-util/cccc/cccc-3.1.6-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs flag-o-matic
DESCRIPTION="Source metrics (line counts, complexity, etc) for Java and C++"
-HOMEPAGE="http://sarnold.github.io/cccc/"
+HOMEPAGE="https://sarnold.github.io/cccc/"
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/sarnold/cccc.git"
EGIT_BRANCH="master"
@@ -20,16 +20,13 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="apidoc debug doc mfc"
-RDEPEND=""
-DEPEND="${RDEPEND}
- apidoc? ( app-doc/doxygen[dot] )
- "
+BDEPEND="apidoc? ( app-doc/doxygen[dot] )"
src_prepare() {
- is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
- use mfc && eapply "${FILESDIR}"/${PN}-c_dialect.patch
default
+ use mfc && eapply "${FILESDIR}"/${PN}-c_dialect.patch
+ is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
}
src_compile() {