summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ccglue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ccglue')
-rw-r--r--dev-util/ccglue/Manifest2
-rw-r--r--dev-util/ccglue/ccglue-0.3.1.ebuild27
-rw-r--r--dev-util/ccglue/ccglue-0.6.0.ebuild21
-rw-r--r--dev-util/ccglue/files/ccglue-0.3.1-as-needed.patch11
-rw-r--r--dev-util/ccglue/files/ccglue-0.5.1-cflags.patch13
-rw-r--r--dev-util/ccglue/metadata.xml13
6 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/ccglue/Manifest b/dev-util/ccglue/Manifest
new file mode 100644
index 000000000000..ea0ae9a4e000
--- /dev/null
+++ b/dev-util/ccglue/Manifest
@@ -0,0 +1,2 @@
+DIST ccglue-release-0.3.1.tar.gz 101529 SHA256 9954bb2af56e8bc313820081f4d45c564b34804978c5a7682846ae98a941b332 SHA512 bbe4c9ff84869696dac80f801fa54df4f60bbe7615d3cd587713f7cd8c58f056db95a003c47879e0ca4fbd3956f97a4b3d31c6d04f49aecca9db2c5ccfaae4b7 WHIRLPOOL 6275b62ea62fcc9911daf3be7a5cd66a6ce9f9dd75df46389a6d728f29069b7c39d0a587435747bb44e98eb24c427975223793b90e43246b9c05fbe37460bd77
+DIST ccglue-release-0.6.0.tar.bz2 220918 SHA256 04b0d83deebf84bee3d18c376891f6f913ed8a053d3f309d8574cb8b1b5abefb SHA512 695983741049d460cac3ae906fddd75380a498062373461efb49b976b958b181301c6a028cc76643bee7fe3b59664aa432d1fb0d43446019a116224ff15107aa WHIRLPOOL 8809b9c95a50c610dfcdb2fb789d4657e61ba266a88e44667aea7cfb0cfc6e205627b233dd5f8571a7c2e7fb6da21f766c62b30020e77d8bb743593b4734cc0a
diff --git a/dev-util/ccglue/ccglue-0.3.1.ebuild b/dev-util/ccglue/ccglue-0.3.1.ebuild
new file mode 100644
index 000000000000..fe123eccc0c7
--- /dev/null
+++ b/dev-util/ccglue/ccglue-0.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Produce cross-reference files from cscope and ctags for use with app-vim/cctree"
+HOMEPAGE="http://ccglue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-release-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/release-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
diff --git a/dev-util/ccglue/ccglue-0.6.0.ebuild b/dev-util/ccglue/ccglue-0.6.0.ebuild
new file mode 100644
index 000000000000..6f14bd92d6ef
--- /dev/null
+++ b/dev-util/ccglue/ccglue-0.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Produce cross-reference files from cscope and ctags for use with app-vim/cctree"
+HOMEPAGE="http://ccglue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-release-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.1-cflags.patch
+ eautoreconf
+}
diff --git a/dev-util/ccglue/files/ccglue-0.3.1-as-needed.patch b/dev-util/ccglue/files/ccglue-0.3.1-as-needed.patch
new file mode 100644
index 000000000000..5f2e5e34c5b5
--- /dev/null
+++ b/dev-util/ccglue/files/ccglue-0.3.1-as-needed.patch
@@ -0,0 +1,11 @@
+--- release-0.3.1/src/Makefile.am.orig
++++ release-0.3.1/src/Makefile.am
+@@ -1,6 +1,4 @@
+ bin_PROGRAMS = ccglue
+ ccglue_SOURCES = cscoperdr.c seqfile.c sym_mgr.c digraph.c options.c main.c c_glue.c
+-INCLUDES = `pkg-config --cflags glib-2.0`
+-AM_LDFLAGS = `pkg-config --libs glib-2.0`
+-
+-
++AM_CFLAGS = $(GLIB_CFLAGS)
++ccglue_LDADD = $(GLIB_LIBS)
diff --git a/dev-util/ccglue/files/ccglue-0.5.1-cflags.patch b/dev-util/ccglue/files/ccglue-0.5.1-cflags.patch
new file mode 100644
index 000000000000..5d0b294f4ca4
--- /dev/null
+++ b/dev-util/ccglue/files/ccglue-0.5.1-cflags.patch
@@ -0,0 +1,13 @@
+--- ccglue_v0.5.1/configure.in
++++ ccglue_v0.5.1/configure.in
+@@ -19,10 +19,7 @@
+ [want_debug="$enableval"], [want_debug=no])
+
+ if test "x$want_debug" = "xyes"; then
+- CXXFLAGS="$CXXFLAGS -O0 -ggdb"
+ AC_DEFINE([DEBUG], 1, [Define for debugging])
+-else
+- CXXFLAGS="$CXXFLAGS -O2"
+ fi
+
+ AC_CXX_HAVE_SSTREAM
diff --git a/dev-util/ccglue/metadata.xml b/dev-util/ccglue/metadata.xml
new file mode 100644
index 000000000000..53a503e1fe5d
--- /dev/null
+++ b/dev-util/ccglue/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <longdescription lang="en">
+ ccglue (ctags-cscope glue) is intended to be the interfacing app between cscope
+ and ctags. It can generate cross-reference tag files that can be interfaced
+ with the Vim CCTree plugin.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ccglue</remote-id>
+ </upstream>
+</pkgmetadata>