summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-04 11:32:20 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-04 22:56:26 -0800
commitf9b14ac2791c1f8e68c5b750bc294e022f3465e3 (patch)
tree40f2a16c11d034ccf5f4bb20977197a2e137d5ce /dev-util/ccls/ccls-9999.ebuild
parentnet-dns/dnsviz: Remove py2 (diff)
downloadgentoo-f9b14ac2791c1f8e68c5b750bc294e022f3465e3.tar.gz
gentoo-f9b14ac2791c1f8e68c5b750bc294e022f3465e3.tar.bz2
gentoo-f9b14ac2791c1f8e68c5b750bc294e022f3465e3.zip
dev-util/ccls: Add new package
Closes: https://bugs.gentoo.org/691060 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/ccls/ccls-9999.ebuild')
-rw-r--r--dev-util/ccls/ccls-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
new file mode 100644
index 000000000000..d959663fa6f0
--- /dev/null
+++ b/dev-util/ccls/ccls-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit cmake ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-libs/rapidjson
+ sys-devel/clang:=
+ sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ )
+ cmake_src_configure
+}