summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-21 08:36:56 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-21 09:33:31 +0100
commit50bcd3f708b3ac9e9fed2bfc0cad267bdf1d93b3 (patch)
tree68bbae28e3e9f76f01a71b7547ea3c34236c5f72 /dev-util/cdiff/cdiff-0.9.8.ebuild
parentdev-python/xlsxwriter: Version Bump (diff)
downloadgentoo-50bcd3f708b3ac9e9fed2bfc0cad267bdf1d93b3.tar.gz
gentoo-50bcd3f708b3ac9e9fed2bfc0cad267bdf1d93b3.tar.bz2
gentoo-50bcd3f708b3ac9e9fed2bfc0cad267bdf1d93b3.zip
dev-util/cdiff: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util/cdiff/cdiff-0.9.8.ebuild')
-rw-r--r--dev-util/cdiff/cdiff-0.9.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/cdiff/cdiff-0.9.8.ebuild b/dev-util/cdiff/cdiff-0.9.8.ebuild
new file mode 100644
index 000000000000..4a10fec9f37e
--- /dev/null
+++ b/dev-util/cdiff/cdiff-0.9.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer"
+HOMEPAGE="https://github.com/ymattw/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ !<app-misc/colordiff-1.0.13-r1
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sys-apps/less"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
+
+DOCS=( CHANGES.rst README.rst )
+
+python_test() {
+ ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}