summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-08-15 15:46:41 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-05 10:53:47 +0300
commit83e6cedff3bc886317d8f4705c8a50534f4118be (patch)
treec1994270feafd6e27a3c80b1bc7254a63f0dfc26 /dev-util/cgdb
parentdev-util/cgdb: revbump for bugfixes (diff)
downloadgentoo-83e6cedff3bc886317d8f4705c8a50534f4118be.tar.gz
gentoo-83e6cedff3bc886317d8f4705c8a50534f4118be.tar.bz2
gentoo-83e6cedff3bc886317d8f4705c8a50534f4118be.zip
dev-util/cgdb: remove broken ebuild
Dropping it due to multiple reported bugs Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/cgdb')
-rw-r--r--dev-util/cgdb/cgdb-0.7.0-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-util/cgdb/cgdb-0.7.0-r1.ebuild b/dev-util/cgdb/cgdb-0.7.0-r1.ebuild
deleted file mode 100644
index 5a8f52e6edac..000000000000
--- a/dev-util/cgdb/cgdb-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="
- https://github.com/cgdb/cgdb.git
- git@github.com:cgdb/cgdb.git"
-else
- SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-fi
-inherit multilib-minimal
-
-DESCRIPTION="A curses front-end for GDB, the GNU debugger"
-HOMEPAGE="http://cgdb.github.io/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- sys-libs/ncurses:0=
- sys-libs/readline:0="
-
-BDEPEND="
- test? (
- dev-util/dejagnu
- app-misc/dtach
- )"
-
-RDEPEND="
- ${DEPEND}
- sys-devel/gdb"
-
-DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
-
-src_prepare() {
- default
- ./autogen.sh || die
-}
-
-multilib_src_test() {
- # Tests need an interactive shell, #654986
-
- # real-time output of the log ;-)
- touch "${T}/dtach-test.log" || die
- tail -f "${T}/dtach-test.log" &
- local tail_pid=${!}
-
- nonfatal dtach -N "${T}/dtach.sock" \
- bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
-
- kill "${tail_pid}"
- [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
- [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf
-}