summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-07-31 00:36:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-07-31 01:02:42 +0200
commitcc95cb8195177267cce59db73dee153f01304fbb (patch)
tree5a58bc65b5a6847881c63fbaf08600a713a0fe2a /dev-util/checkbashisms/checkbashisms-2.19.6.ebuild
parentapp-text/libstaroffice: arm64 stable (diff)
downloadgentoo-cc95cb8195177267cce59db73dee153f01304fbb.tar.gz
gentoo-cc95cb8195177267cce59db73dee153f01304fbb.tar.bz2
gentoo-cc95cb8195177267cce59db73dee153f01304fbb.zip
dev-util/checkbashisms: bump to v2.19.6
(no changes) Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.19.6.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.19.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.19.6.ebuild b/dev-util/checkbashisms/checkbashisms-2.19.6.ebuild
new file mode 100644
index 000000000000..e48d94ca95a3
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.19.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long
+ !<dev-util/rpmdevtools-8.3-r1"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ default
+
+ eapply -p2 "${FILESDIR}"/${PN}-2.18.6-command-vV.patch
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}