summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-01 15:10:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-01 15:22:51 +0200
commitd50ea6cda8ddc4b056acd4aacfeacdbc91d401cd (patch)
tree193b58aac4455e8538d13a563e92b65749cb2484 /dev-util/checkbashisms/checkbashisms-2.20.3.ebuild
parentdev-util/byacc: bump to v20200330 (diff)
downloadgentoo-d50ea6cda8ddc4b056acd4aacfeacdbc91d401cd.tar.gz
gentoo-d50ea6cda8ddc4b056acd4aacfeacdbc91d401cd.tar.bz2
gentoo-d50ea6cda8ddc4b056acd4aacfeacdbc91d401cd.zip
dev-util/checkbashisms: bump to v2.20.3
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.20.3.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.20.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.20.3.ebuild b/dev-util/checkbashisms/checkbashisms-2.20.3.ebuild
new file mode 100644
index 000000000000..26d0ab390329
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.20.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://anonscm.debian.org/cgit/collab-maint/devscripts.git"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ default
+
+ eapply -p2 "${FILESDIR}"/${PN}-2.18.6-command-vV.patch
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}