summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-21 00:55:17 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-21 00:55:43 +0100
commitde23cfb3e4c17327d1d71a74e779249f2a5e73cd (patch)
tree4323d03863bd645263908b1566d8529275788d14 /dev-util/checkbashisms/checkbashisms-2.20.5.ebuild
parentsys-block/storcli: amd64 stable (diff)
downloadgentoo-de23cfb3e4c17327d1d71a74e779249f2a5e73cd.tar.gz
gentoo-de23cfb3e4c17327d1d71a74e779249f2a5e73cd.tar.bz2
gentoo-de23cfb3e4c17327d1d71a74e779249f2a5e73cd.zip
dev-util/checkbashisms: bump to v2.20.5
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-util/checkbashisms/checkbashisms-2.20.5.ebuild')
-rw-r--r--dev-util/checkbashisms/checkbashisms-2.20.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/checkbashisms/checkbashisms-2.20.5.ebuild b/dev-util/checkbashisms/checkbashisms-2.20.5.ebuild
new file mode 100644
index 000000000000..1d567b48dc59
--- /dev/null
+++ b/dev-util/checkbashisms/checkbashisms-2.20.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="devscripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Perl script to check for commonly used bash features not defined by POSIX"
+HOMEPAGE="https://packages.debian.org/devscripts https://salsa.debian.org/debian/devscripts"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Requires python packages to check tools we don't need anyway
+RESTRICT="test"
+
+RDEPEND="dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S="${WORKDIR}/${MY_P}/scripts"
+
+src_prepare() {
+ default
+
+ sed "s@###VERSION###@${PV}@" -i checkbashisms.pl || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ newbin ${PN}.pl ${PN}
+ doman ${PN}.1
+}