summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-05-15 13:23:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-05-15 13:23:32 +0200
commitfd98b3a47c54ebebf6bbd49fcc0fcbefc8d39238 (patch)
treedc61823186870b74d04d085d1bf6f46a6b045a7c /dev-util/clair
parentapp-emulation/kompose: Remove old (diff)
downloadgentoo-fd98b3a47c54ebebf6bbd49fcc0fcbefc8d39238.tar.gz
gentoo-fd98b3a47c54ebebf6bbd49fcc0fcbefc8d39238.tar.bz2
gentoo-fd98b3a47c54ebebf6bbd49fcc0fcbefc8d39238.zip
dev-util/clair: Version bump to 2.0.3
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-util/clair')
-rw-r--r--dev-util/clair/Manifest1
-rw-r--r--dev-util/clair/clair-2.0.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/clair/Manifest b/dev-util/clair/Manifest
index 062e7e95e414..e546d59178d4 100644
--- a/dev-util/clair/Manifest
+++ b/dev-util/clair/Manifest
@@ -1,2 +1,3 @@
DIST clair-2.0.1.tar.gz 5194465 BLAKE2B b91bc130ce7237c5398715bfd91f6744d89bd9690ddd5d99aabbcc62b22c148dbbe2594d1c1376010d9cd992012d639ceef4e9a78d1837c633978f52b4d223ae SHA512 03293829426d81157860effd893b72164679b4ec40c19294e321d489ced67dfea72415cdd9b1005ae590367c68f746664a76f63a29c7d714b22917f2323c4937
DIST clair-2.0.2.tar.gz 5194625 BLAKE2B a1866ec881036a3f3891935782ccb4709c26a8051b4d762be2e7eae2da11ecbad794d21fd2d62c842f5d6d18a8f203a2258d9e9fad985455becc494753c75e43 SHA512 1522c40059594f8f7ce17781269a3511e987173c741c550e5c0b87beaabe73e368a23ddd75a2499a6e9f8920308744809c4c938af31cdb93ce2f0a817f906674
+DIST clair-2.0.3.tar.gz 5194681 BLAKE2B b4f809e7699fbf66745c7f528f3f2c249e81541a64c540a8c39b9fa8f5b581d1297abdfe80bdb0ca3aec00010c6c95e8073397df284d2a92a3e95f91049cde80 SHA512 bf2d4ab15efc50bce3e828d0510ceb44463a6c1d978a854b3a05899996203a7c33bb6e60470eccb6e0a1e23b8ff41955cd0fdda4b77a9a7e042e1e27dd2e0885
diff --git a/dev-util/clair/clair-2.0.3.ebuild b/dev-util/clair/clair-2.0.3.ebuild
new file mode 100644
index 000000000000..8c92e5db7e56
--- /dev/null
+++ b/dev-util/clair/clair-2.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/coreos/clair"
+EGIT_COMMIT="v${PV}"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Vulnerability Static Analysis for Containers"
+HOMEPAGE="https://github.com/coreos/clair"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/rpm
+ app-arch/xz-utils
+ dev-vcs/bzr
+ dev-vcs/git
+ !!sci-visualization/xd3d" # File collision (Bug #621044)
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/${PN} -v ${EGO_PN}/cmd/${PN} || die
+}
+
+src_install() {
+ dobin bin/${PN}
+ pushd src/${EGO_PN} || die
+ dodoc {README,ROADMAP,CONTRIBUTING}.md
+ insinto /etc/${PN}
+ doins config.example.yaml
+ popd || die
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}