summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-10 23:59:25 +0000
committerSam James <sam@gentoo.org>2021-12-13 00:11:30 +0000
commit53bb19912117d36da9df66dca656213347391006 (patch)
tree9e72f0dab9049c2602de47ec8b640231ff49e00a /dev-util/clazy
parentdev-util/clazy: use llvm.eclass to declare compatibility and build patch (diff)
downloadgentoo-53bb19912117d36da9df66dca656213347391006.tar.gz
gentoo-53bb19912117d36da9df66dca656213347391006.tar.bz2
gentoo-53bb19912117d36da9df66dca656213347391006.zip
dev-util/clazy: BDEPEND on Python for tests
Avoid using 'python3' directly. Still not passing for me though. Bug: https://bugs.gentoo.org/811723 Signed-off-by: Sam James <sam@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/23246 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/clazy')
-rw-r--r--dev-util/clazy/clazy-1.10-r1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-util/clazy/clazy-1.10-r1.ebuild b/dev-util/clazy/clazy-1.10-r1.ebuild
index d8369600c480..f6c1247cc4ed 100644
--- a/dev-util/clazy/clazy-1.10-r1.ebuild
+++ b/dev-util/clazy/clazy-1.10-r1.ebuild
@@ -4,7 +4,8 @@
EAPI=7
LLVM_MAX_SLOT=12
-inherit cmake llvm
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit cmake llvm python-any-r1
DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
HOMEPAGE="https://apps.kde.org/clazy"
@@ -13,10 +14,12 @@ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~amd64 arm64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="<sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):="
DEPEND="${RDEPEND}"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
PATCHES=(
"${FILESDIR}"/${P}-gcc-build.patch
@@ -27,6 +30,12 @@ llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}" && has_version "sys-devel/llvm:${LLVM_SLOT}"
}
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+
+ llvm_pkg_setup
+}
+
src_prepare() {
cmake_src_prepare