summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 14:53:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 14:53:45 +0100
commitf1c92c1d6530aeb22382ab74c9a2113da5617024 (patch)
tree8f03f37b0c5878524c3447e832b37e1856b1f899 /dev-util/clazy
parentdev-python/poetry-core: keyword 1.0.7 for ~riscv (diff)
downloadgentoo-f1c92c1d6530aeb22382ab74c9a2113da5617024.tar.gz
gentoo-f1c92c1d6530aeb22382ab74c9a2113da5617024.tar.bz2
gentoo-f1c92c1d6530aeb22382ab74c9a2113da5617024.zip
dev-util/clazy: Drop 1.9
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/clazy')
-rw-r--r--dev-util/clazy/Manifest1
-rw-r--r--dev-util/clazy/clazy-1.9.ebuild40
-rw-r--r--dev-util/clazy/files/clazy-1.9-llvm12.patch88
-rw-r--r--dev-util/clazy/files/clazy-1.9-llvm13.patch31
4 files changed, 0 insertions, 160 deletions
diff --git a/dev-util/clazy/Manifest b/dev-util/clazy/Manifest
index 1a0031b71ddc..eae6b70fd4c9 100644
--- a/dev-util/clazy/Manifest
+++ b/dev-util/clazy/Manifest
@@ -1,2 +1 @@
DIST clazy-1.10.tar.xz 398920 BLAKE2B 1cdc160de21363c7dc9c93ea7e780412a4971b18e97c7ec6e06f1c7450c56e0fbbdb7592d6b92ae53e4c161f6d9abca205984f83b68646f04ea11d63e3c45fa6 SHA512 59dd8c6903bcc239dfc356804cab265597a771de3858a6add4877149e0e7875b3c9ddae9aeec889c9102fb9ec6b0125bb8a786344e47872b01ba87425ba021eb
-DIST clazy-1.9.tar.xz 394856 BLAKE2B 641ca46a31475cf7bd03ba921e390cb2712362dc97b960a519e05c47049927f805d3ef6f1c756b96d3483e8f4b75e2dc41a2419a462ed2e45cbd08c88c07f933 SHA512 2e8bec44a027366263de23c50d14192e310fd38fa2b369afb21413da9cb78da9882b2153daf1784c4c9076cc62e2867b5211c75ff9a1eabcb583e405f20f5912
diff --git a/dev-util/clazy/clazy-1.9.ebuild b/dev-util/clazy/clazy-1.9.ebuild
deleted file mode 100644
index 781b51040559..000000000000
--- a/dev-util/clazy/clazy-1.9.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
-HOMEPAGE="https://apps.kde.org/en/clazy"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE=""
-
-RDEPEND="
- >=sys-devel/clang-5.0:=
- >=sys-devel/llvm-5.0:=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-llvm{12,13}.patch ) # bug 786525
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e '/install(FILES README.md COPYING-LGPL2.txt checks.json DESTINATION/d' \
- -i CMakeLists.txt || die
-}
-
-src_configure() {
- # this package requires both llvm and clang of the same version.
- # clang pulls in the equivalent llvm version, but not vice versa.
- # so, we must find llvm based on the installed clang version.
- # bug #681568
- local clang_version=$(best_version "sys-devel/clang")
- export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
- cmake_src_configure
-}
diff --git a/dev-util/clazy/files/clazy-1.9-llvm12.patch b/dev-util/clazy/files/clazy-1.9-llvm12.patch
deleted file mode 100644
index 3862f40ad981..000000000000
--- a/dev-util/clazy/files/clazy-1.9-llvm12.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 2592a6e3393ebc75e16c91e606ad2015a16295c3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Christian=20Sch=C3=A4rf?= <c.schaerf@t-online.de>
-Date: Sat, 23 Jan 2021 15:34:10 +0100
-Subject: [PATCH] Fix build with Clang 12
-
-Required due to Clang changes https://github.com/llvm/llvm-project/commit/b3eff6b7bb31e7ef059a3d238de138849839fbbd and https://github.com/llvm/llvm-project/commit/d758f79e5d381bd4f5122193a9538d89c907c812
----
- src/SourceCompatibilityHelpers.h | 26 ++++++++++++++++++++++++++
- src/SuppressionManager.cpp | 5 ++---
- 2 files changed, 28 insertions(+), 3 deletions(-)
-
-diff --git a/src/SourceCompatibilityHelpers.h b/src/SourceCompatibilityHelpers.h
-index 4db141ab..1737d5a5 100644
---- a/src/SourceCompatibilityHelpers.h
-+++ b/src/SourceCompatibilityHelpers.h
-@@ -29,6 +29,7 @@
- #include <clang/Basic/SourceLocation.h>
- #include <clang/Basic/SourceManager.h>
- #include <clang/Frontend/FrontendDiagnostic.h>
-+#include <clang/Lex/Lexer.h>
- #include <clang/Tooling/Core/Diagnostic.h>
-
- #if defined(CLAZY_USES_BOOST_REGEX)
-@@ -103,6 +104,31 @@ inline clang::tooling::Replacements& DiagnosticFix(clang::tooling::Diagnostic &d
- #endif
- }
-
-+inline auto getBuffer(const clang::SourceManager &sm, clang::FileID id, bool *invalid)
-+{
-+#if LLVM_VERSION_MAJOR >= 12
-+ auto buffer = sm.getBufferOrNone(id);
-+ *invalid = !buffer.hasValue();
-+ return buffer;
-+#else
-+ return sm.getBuffer(id, invalid);
-+#endif
-+}
-+
-+#if LLVM_VERSION_MAJOR >= 12
-+inline clang::Lexer getLexer(clang::FileID id, llvm::Optional<llvm::MemoryBufferRef> inputFile,
-+ const clang::SourceManager &sm, const clang::LangOptions &lo)
-+{
-+ return clang::Lexer(id, inputFile.getValue(), sm, lo);
-+}
-+#else
-+inline clang::Lexer getLexer(clang::FileID id, const llvm::MemoryBuffer *inputFile,
-+ const clang::SourceManager &sm, const clang::LangOptions &lo)
-+{
-+ return clang::Lexer(id, inputFile, sm, lo);
-+}
-+#endif
-+
- }
-
- #endif
-diff --git a/src/SuppressionManager.cpp b/src/SuppressionManager.cpp
-index 9d774ea6..9881388d 100644
---- a/src/SuppressionManager.cpp
-+++ b/src/SuppressionManager.cpp
-@@ -24,7 +24,6 @@
- #include "clazy_stl.h"
-
- #include <clang/Basic/SourceManager.h>
--#include <clang/Lex/Lexer.h>
- #include <clang/Basic/SourceLocation.h>
- #include <clang/Basic/TokenKinds.h>
- #include <clang/Lex/Token.h>
-@@ -84,7 +83,7 @@ void SuppressionManager::parseFile(FileID id, const SourceManager &sm, const cla
- Suppressions &suppressions = (*it).second;
-
- bool invalid = false;
-- auto buffer = sm.getBuffer(id, &invalid);
-+ auto buffer = clazy::getBuffer(sm, id, &invalid);
- if (invalid) {
- llvm::errs() << "SuppressionManager::parseFile: Invalid buffer ";
- if (buffer)
-@@ -92,7 +91,7 @@ void SuppressionManager::parseFile(FileID id, const SourceManager &sm, const cla
- return;
- }
-
-- Lexer lexer(id, buffer, sm, lo);
-+ auto lexer = clazy::getLexer(id, buffer, sm, lo);
- lexer.SetCommentRetentionState(true);
-
- Token token;
---
-GitLab
-
diff --git a/dev-util/clazy/files/clazy-1.9-llvm13.patch b/dev-util/clazy/files/clazy-1.9-llvm13.patch
deleted file mode 100644
index 9bbac8f7624d..000000000000
--- a/dev-util/clazy/files/clazy-1.9-llvm13.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 0bf4e428c76270f4534a0a8df3cf6912157f22ab Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
-Date: Sat, 17 Apr 2021 20:57:10 +0200
-Subject: [PATCH] Fix build with LLVM 13
-
----
- src/ClazyStandaloneMain.cpp | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/src/ClazyStandaloneMain.cpp b/src/ClazyStandaloneMain.cpp
-index 41c4fcf9..7b4cf5d3 100644
---- a/src/ClazyStandaloneMain.cpp
-+++ b/src/ClazyStandaloneMain.cpp
-@@ -158,7 +158,13 @@ llvm::IntrusiveRefCntPtr<vfs::FileSystem> getVfsFromFile(const std::string &over
-
- int main(int argc, const char **argv)
- {
-- CommonOptionsParser optionsParser(argc, argv, s_clazyCategory, cl::ZeroOrMore);
-+ auto expectedParser = CommonOptionsParser::create(argc, argv, s_clazyCategory, cl::ZeroOrMore);
-+ if (!expectedParser) {
-+ llvm::errs() << expectedParser.takeError();
-+ return 1;
-+ }
-+
-+ auto &optionsParser = expectedParser.get();
- // llvm::errs() << optionsParser.getSourcePathList().size() << "\n";
-
- if (s_supportedChecks.getValue()) {
---
-GitLab
-