summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-11-20 09:15:30 -0500
committerCraig Andrews <candrews@gentoo.org>2020-11-20 09:15:58 -0500
commita25117619ed8746b9e0593f4e5406e10b113438d (patch)
treec501acfd6e6e8cce5a54e1f8f4eeca379bd1648b /dev-util/clinfo/clinfo-3.0.20.11.20.ebuild
parentdev-python/pytest-django: ppc keyworded (bug #752396) (diff)
downloadgentoo-a25117619ed8746b9e0593f4e5406e10b113438d.tar.gz
gentoo-a25117619ed8746b9e0593f4e5406e10b113438d.tar.bz2
gentoo-a25117619ed8746b9e0593f4e5406e10b113438d.zip
dev-util/clinfo: 3.0.20.11.20 version bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/clinfo/clinfo-3.0.20.11.20.ebuild')
-rw-r--r--dev-util/clinfo/clinfo-3.0.20.11.20.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/clinfo/clinfo-3.0.20.11.20.ebuild b/dev-util/clinfo/clinfo-3.0.20.11.20.ebuild
new file mode 100644
index 000000000000..fc1ca3477ce1
--- /dev/null
+++ b/dev-util/clinfo/clinfo-3.0.20.11.20.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=virtual/opencl-3"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}