summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2016-10-11 22:42:29 -0400
committerPatrice Clement <monsieurp@gentoo.org>2016-10-14 08:47:57 +0200
commitb769aa12804e061775976effd1dee0be3486f5e0 (patch)
tree10b473923163b9b7124b8c15bed1cd8ae74b8366 /dev-util/cloc/cloc-1.70.ebuild
parentmail-mta/opensmtpd: regenerate Manifest file. (diff)
downloadgentoo-b769aa12804e061775976effd1dee0be3486f5e0.tar.gz
gentoo-b769aa12804e061775976effd1dee0be3486f5e0.tar.bz2
gentoo-b769aa12804e061775976effd1dee0be3486f5e0.zip
dev-util/cloc: version bump 1.70.
Acked-by: Matthias Maier <tamiko@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/2542 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-util/cloc/cloc-1.70.ebuild')
-rw-r--r--dev-util/cloc/cloc-1.70.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cloc/cloc-1.70.ebuild b/dev-util/cloc/cloc-1.70.ebuild
new file mode 100644
index 000000000000..79666b2519b3
--- /dev/null
+++ b/dev-util/cloc/cloc-1.70.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Count Lines of Code"
+HOMEPAGE="https://github.com/AlDanial/cloc"
+SRC_URI="https://github.com/AlDanial/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/Algorithm-Diff
+ dev-perl/Regexp-Common
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+
+src_compile() {
+ pod2man "Unix/${PN}.1.pod" > "${PN}.1" || die
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "Unix/${PN}"
+}