summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-27 11:06:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-27 11:06:07 +0100
commit65187c84488d7759ccd0be31071d3425efc02a6e (patch)
tree11f3980d8d806fb6362c3c0e15a7b1c32ba5e5a0 /dev-util/cmake
parentsys-fs/xfsprogs: Bump to version 4.15.1 (diff)
downloadgentoo-65187c84488d7759ccd0be31071d3425efc02a6e.tar.gz
gentoo-65187c84488d7759ccd0be31071d3425efc02a6e.tar.bz2
gentoo-65187c84488d7759ccd0be31071d3425efc02a6e.zip
dev-util/cmake: Replaced pthread patch with official upstream fix.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/cmake-3.11.0_rc1.ebuild2
-rw-r--r--dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch21
-rw-r--r--dev-util/cmake/files/cmake-3.11.0_rc1-system_thread.patch44
3 files changed, 45 insertions, 22 deletions
diff --git a/dev-util/cmake/cmake-3.11.0_rc1.ebuild b/dev-util/cmake/cmake-3.11.0_rc1.ebuild
index a1fdde41672d..85d191ee0dc5 100644
--- a/dev-util/cmake/cmake-3.11.0_rc1.ebuild
+++ b/dev-util/cmake/cmake-3.11.0_rc1.ebuild
@@ -60,9 +60,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
"${FILESDIR}"/${PN}-3.9.0_rc2-FindPythonInterp.patch
- "${FILESDIR}"/${PN}-3.11.0_rc1-add_missing_pthread.patch
# upstream fixes (can usually be removed with a version bump)
+ "${FILESDIR}"/${PN}-3.11.0_rc1-system_thread.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch b/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
deleted file mode 100644
index 3a4c4352c6ff..000000000000
--- a/dev-util/cmake/files/cmake-3.11.0_rc1-add_missing_pthread.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- cmake-3.11.0-rc1/Source/CMakeLists.txt
-+++ cmake-3.11.0-rc1/Source/CMakeLists.txt
-@@ -765,6 +765,7 @@
- ${CMAKE_LIBUV_LIBRARIES}
- ${CMAKE_LIBRHASH_LIBRARIES}
- ${CMake_KWIML_LIBRARIES}
-+ pthread
- )
-
- if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
---- cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
-+++ cmake-3.11.0-rc1/Tests/CMakeLib/CMakeLists.txt
-@@ -30,7 +30,7 @@
-
- create_test_sourcelist(CMakeLib_TEST_SRCS CMakeLibTests.cxx ${CMakeLib_TESTS})
- add_executable(CMakeLibTests ${CMakeLib_TEST_SRCS})
--target_link_libraries(CMakeLibTests CMakeLib)
-+target_link_libraries(CMakeLibTests CMakeLib pthread)
-
- set_property(TARGET CMakeLibTests PROPERTY C_CLANG_TIDY "")
- set_property(TARGET CMakeLibTests PROPERTY CXX_CLANG_TIDY "")
diff --git a/dev-util/cmake/files/cmake-3.11.0_rc1-system_thread.patch b/dev-util/cmake/files/cmake-3.11.0_rc1-system_thread.patch
new file mode 100644
index 000000000000..b2ac2be99d41
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.11.0_rc1-system_thread.patch
@@ -0,0 +1,44 @@
+From 94eee5e683b80e0ffd8e0c4fd3a45b03f0f37b18 Mon Sep 17 00:00:00 2001
+From: Brad King <brad.king@kitware.com>
+Date: Thu, 22 Feb 2018 12:57:29 -0500
+Subject: [PATCH] CMakeLib: Link to system thread libraries to support std::thread
+
+Some environments require linking to thread libraries for `std::thread`.
+Express this direct dependency of CMakeLib explicitly. Previously this
+was done indirectly through our bundled libuv, but that does not work
+when using a system libuv.
+
+Fixes: #17757
+---
+ CMakeLists.txt | 2 ++
+ Source/CMakeLists.txt | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e4d2a9a..6623959 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -310,6 +310,8 @@ endmacro()
+ # Simply to improve readability of the main script.
+ #-----------------------------------------------------------------------
+ macro (CMAKE_BUILD_UTILITIES)
++ find_package(Threads)
++
+ #---------------------------------------------------------------------
+ # Create the kwsys library for CMake.
+ set(KWSYS_NAMESPACE cmsys)
+diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
+index e7c0732..a0010a2 100644
+--- a/Source/CMakeLists.txt
++++ b/Source/CMakeLists.txt
+@@ -765,6 +765,7 @@ target_link_libraries(CMakeLib cmsys
+ ${CMAKE_LIBUV_LIBRARIES}
+ ${CMAKE_LIBRHASH_LIBRARIES}
+ ${CMake_KWIML_LIBRARIES}
++ ${CMAKE_THREAD_LIBS_INIT}
+ )
+
+ if(CMAKE_SYSTEM_NAME STREQUAL "Linux" AND CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
+--
+libgit2 0.26.0
+