summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cmocka/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cmocka/files')
-rw-r--r--dev-util/cmocka/files/cmocka-automagicness.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-util/cmocka/files/cmocka-automagicness.patch b/dev-util/cmocka/files/cmocka-automagicness.patch
new file mode 100644
index 000000000000..29ece4563214
--- /dev/null
+++ b/dev-util/cmocka/files/cmocka-automagicness.patch
@@ -0,0 +1,74 @@
+--- a/cmake/Modules/MacroOptionalFindPackage.cmake
++++ b/cmake/Modules/MacroOptionalFindPackage.cmake
+@@ -0,0 +1,48 @@
++# - MACRO_OPTIONAL_FIND_PACKAGE() combines FIND_PACKAGE() with an OPTION()
++# MACRO_OPTIONAL_FIND_PACKAGE( <name> [QUIT] )
++# This macro is a combination of OPTION() and FIND_PACKAGE(), it
++# works like FIND_PACKAGE(), but additionally it automatically creates
++# an option name WITH_<name>, which can be disabled via the cmake GUI.
++# or via -DWITH_<name>=OFF
++# The standard <name>_FOUND variables can be used in the same way
++# as when using the normal FIND_PACKAGE()
++
++# Copyright (c) 2006-2010 Alexander Neundorf, <neundorf@kde.org>
++#
++# Redistribution and use is allowed according to the terms of the BSD license.
++# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
++
++# This is just a helper macro to set a bunch of variables empty.
++# We don't know whether the package uses UPPERCASENAME or CamelCaseName, so we try both:
++macro(_MOFP_SET_EMPTY_IF_DEFINED _name _var)
++ if(DEFINED ${_name}_${_var})
++ set(${_name}_${_var} "")
++ endif(DEFINED ${_name}_${_var})
++
++ string(TOUPPER ${_name} _nameUpper)
++ if(DEFINED ${_nameUpper}_${_var})
++ set(${_nameUpper}_${_var} "")
++ endif(DEFINED ${_nameUpper}_${_var})
++endmacro(_MOFP_SET_EMPTY_IF_DEFINED _package _var)
++
++
++macro (MACRO_OPTIONAL_FIND_PACKAGE _name )
++ option(WITH_${_name} "Search for ${_name} package" ON)
++ if (WITH_${_name})
++ find_package(${_name} ${ARGN})
++ else (WITH_${_name})
++ string(TOUPPER ${_name} _nameUpper)
++ set(${_name}_FOUND FALSE)
++ set(${_nameUpper}_FOUND FALSE)
++
++ _mofp_set_empty_if_defined(${_name} INCLUDE_DIRS)
++ _mofp_set_empty_if_defined(${_name} INCLUDE_DIR)
++ _mofp_set_empty_if_defined(${_name} INCLUDES)
++ _mofp_set_empty_if_defined(${_name} LIBRARY)
++ _mofp_set_empty_if_defined(${_name} LIBRARIES)
++ _mofp_set_empty_if_defined(${_name} LIBS)
++ _mofp_set_empty_if_defined(${_name} FLAGS)
++ _mofp_set_empty_if_defined(${_name} DEFINITIONS)
++ endif (WITH_${_name})
++endmacro (MACRO_OPTIONAL_FIND_PACKAGE)
++
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -34,7 +34,7 @@
+ include(DefineInstallationPaths)
+ include(DefineOptions.cmake)
+ include(CPackConfig.cmake)
+-
++include(MacroOptionalFindPackage)
+ if (UNIT_TESTING)
+ include(AddCMockaTest)
+ endif (UNIT_TESTING)
+--- a/doc/CMakeLists.txt
++++ b/doc/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ #
+ # Build the documentation
+ #
+-include(UseDoxygen OPTIONAL)
+-
++option(WITH_APIDOC "Use doxygen to generate documentation" ON)
++if (WITH_APIDOC)
++ include(UseDoxygen OPTIONAL)
++endif (WITH_APIDOC)