summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 13:57:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:43 +0100
commit4204aed71ec2d1b2413df056e74191a61c393e53 (patch)
tree16b5bd4eebd1657716b36eca8e4c399a1bcf8638 /dev-util/cmocka
parentcmake-multilib.eclass: Add CMAKE_ECLASS switch (diff)
downloadgentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.gz
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.bz2
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.zip
*/*: Switch kde proj packages using cmake-multilib.eclass to cmake
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/cmocka')
-rw-r--r--dev-util/cmocka/cmocka-1.1.5.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/cmocka/cmocka-1.1.5.ebuild b/dev-util/cmocka/cmocka-1.1.5.ebuild
index eecc4f26cc8c..1d03a7176914 100644
--- a/dev-util/cmocka/cmocka-1.1.5.ebuild
+++ b/dev-util/cmocka/cmocka-1.1.5.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Unit testing framework for C"
@@ -24,16 +25,16 @@ multilib_src_configure() {
-DWITH_EXAMPLES=$(usex examples)
-DWITH_STATIC_LIB=$(usex static-libs)
-DUNIT_TESTING=$(usex test)
- $(multilib_is_native_abi && cmake-utils_use_find_package doc Doxygen \
+ $(multilib_is_native_abi && cmake_use_find_package doc Doxygen \
|| echo -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
}
multilib_src_install() {
@@ -41,5 +42,5 @@ multilib_src_install() {
local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
fi
- cmake-utils_src_install
+ cmake_src_install
}