summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-29 19:24:58 +0100
committerSam James <sam@gentoo.org>2022-10-29 19:25:55 +0100
commit6a0bb8ca841da9af29e49ae2c024ce9667d5c9d5 (patch)
tree7a0629c22986ccc4a4afae1dab237a8cc41f0c58 /dev-util/coccigrep
parentdev-util/coccinelle: new package, add 1.1.1 (diff)
downloadgentoo-6a0bb8ca841da9af29e49ae2c024ce9667d5c9d5.tar.gz
gentoo-6a0bb8ca841da9af29e49ae2c024ce9667d5c9d5.tar.bz2
gentoo-6a0bb8ca841da9af29e49ae2c024ce9667d5c9d5.zip
dev-util/coccigrep: new package, add 1.20
It was removed in the past because of no Python 3 support, but it supports Python 3 now. Bug: https://bugs.gentoo.org/734630 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/coccigrep')
-rw-r--r--dev-util/coccigrep/Manifest1
-rw-r--r--dev-util/coccigrep/coccigrep-1.20.ebuild63
-rw-r--r--dev-util/coccigrep/files/50coccigrep-gentoo.el4
-rw-r--r--dev-util/coccigrep/metadata.xml11
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/coccigrep/Manifest b/dev-util/coccigrep/Manifest
new file mode 100644
index 000000000000..0e2c0c93af48
--- /dev/null
+++ b/dev-util/coccigrep/Manifest
@@ -0,0 +1 @@
+DIST coccigrep-1.20.tar.gz 33027 BLAKE2B b4d38662beaa5ad6972e21e33523c9c7253f9f124067c45b21fc0234b6aa6338481a9a3a08242c3c4227ac102b75ff7070bd7d7dcec31193d84367d1d739072d SHA512 35d6a43b515c261ba025b876a72566581f892624eb9f47cde4121f16b2922ead8cd94e2c0ea6e00e4c64a3fe0cdcc4aeadc4c49900a8de8cfc0b589208ecae9c
diff --git a/dev-util/coccigrep/coccigrep-1.20.ebuild b/dev-util/coccigrep/coccigrep-1.20.ebuild
new file mode 100644
index 000000000000..f439caae2e86
--- /dev/null
+++ b/dev-util/coccigrep/coccigrep-1.20.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 elisp-common optfeature
+
+DESCRIPTION="A semantic grep for the C language"
+HOMEPAGE="http://home.regit.org/software/coccigrep/"
+SRC_URI="https://github.com/regit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs"
+
+RDEPEND="
+ dev-util/coccinelle[python,${PYTHON_SINGLE_USEDEP}]
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+BDEPEND="
+ doc? ( dev-python/sphinx )
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+python_compile_all() {
+ use doc && emake -C doc html
+
+ if use emacs ; then
+ elisp-compile editors/*.el || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+
+ if use emacs ; then
+ elisp-install ${PN} editors/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins editors/cocci-grep.vim
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ optfeature "Syntax highlighting (colorized output formats)" dev-python/pygments
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccigrep/files/50coccigrep-gentoo.el b/dev-util/coccigrep/files/50coccigrep-gentoo.el
new file mode 100644
index 000000000000..7fbc6b93e541
--- /dev/null
+++ b/dev-util/coccigrep/files/50coccigrep-gentoo.el
@@ -0,0 +1,4 @@
+;;; coccigrep site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'cocci-grep)
diff --git a/dev-util/coccigrep/metadata.xml b/dev-util/coccigrep/metadata.xml
new file mode 100644
index 000000000000..69ff36f5dcae
--- /dev/null
+++ b/dev-util/coccigrep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">regit/coccigrep</remote-id>
+ </upstream>
+</pkgmetadata>