summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/colorgcc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/colorgcc')
-rw-r--r--dev-util/colorgcc/Manifest1
-rw-r--r--dev-util/colorgcc/colorgcc-1.3.2-r4.ebuild63
-rw-r--r--dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild65
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch242
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch75
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-note.patch57
-rw-r--r--dev-util/colorgcc/metadata.xml5
7 files changed, 508 insertions, 0 deletions
diff --git a/dev-util/colorgcc/Manifest b/dev-util/colorgcc/Manifest
new file mode 100644
index 000000000000..8539635666ba
--- /dev/null
+++ b/dev-util/colorgcc/Manifest
@@ -0,0 +1 @@
+DIST colorgcc-1.3.2.tar.gz 11076 SHA256 55d33a64628ff380626b864200cad72146d00f3dce0f6dc1f0e69dc5b7f1653e SHA512 1f6031bcc0f6eb6bdaf0359debe13d1a6579c4f5bfb8dfeef79904a2ffcc94322f2c7f9948439c2975bd4ffed1ebaa085bd7ce338289bdf9c170cd40e1c1a448 WHIRLPOOL 6059d552558aa81a0c702dc678befb4b6403377edb6f57712439a61f7f2ceccd65fc8b61d0c901a2802493769956f9e4e23b57524084c57e4602ba9cd4a97a10
diff --git a/dev-util/colorgcc/colorgcc-1.3.2-r4.ebuild b/dev-util/colorgcc/colorgcc-1.3.2-r4.ebuild
new file mode 100644
index 000000000000..cb6c9d38c84e
--- /dev/null
+++ b/dev-util/colorgcc/colorgcc-1.3.2-r4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Adds color to gcc output"
+HOMEPAGE="http://schlueters.de/colorgcc.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ~hppa ~mips ppc sparc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo-one.patch \
+ "${FILESDIR}"/${P}-gentoo-two.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin colorgcc || die
+ dodir /etc/colorgcc /usr/lib/colorgcc/bin
+ insinto /etc/colorgcc
+ doins colorgccrc || die
+ einfo "Scanning for compiler front-ends"
+ into /usr/lib/colorgcc/bin
+ for a in gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ ; do
+ if [ -n "$(type -p ${a})" ]; then
+ dosym /usr/bin/colorgcc /usr/lib/colorgcc/bin/${a}
+ fi
+ done
+
+ dodoc CREDITS ChangeLog || die
+}
+
+pkg_postinst() {
+ echo
+ elog "If you have existing \$HOME/.colorgccrc files that set the location"
+ elog "of the compilers, you should remove those lines for maximum"
+ elog "flexibility. The colorgcc script now knows how to pass the command"
+ elog "on to the next step in the PATH without manual tweaking, making it"
+ elog "easier to use with things like ccache and distcc on a conditional"
+ elog "basis. You can tweak the /etc/colorgcc/colorgccrc file to change"
+ elog "the default settings for everyone (or copy this file as a basis for"
+ elog "a custom \$HOME/.colorgccrc file)."
+ elog
+ elog "NOTE: the symlinks for colorgcc are now located in"
+ elog "/usr/lib/colorgcc/bin *NOT* /usr/bin/wrappers. You'll need to"
+ elog "change any PATH settings that referred to the old location."
+ echo
+ # portage won't delete the old symlinks for users that are upgrading
+ # because the old symlinks still point to /usr/bin/colorgcc which exists...
+ [ -d "${ROOT}"/usr/bin/wrappers ] && rm -fr "${ROOT}"/usr/bin/wrappers
+}
diff --git a/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild b/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild
new file mode 100644
index 000000000000..9b659857bbe7
--- /dev/null
+++ b/dev-util/colorgcc/colorgcc-1.3.2-r5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="Adds color to gcc output"
+HOMEPAGE="http://schlueters.de/colorgcc.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 hppa ~mips ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo-one.patch \
+ "${FILESDIR}"/${P}-gentoo-two.patch \
+ "${FILESDIR}"/${P}-note.patch
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ dobin colorgcc || die
+ dodir /etc/colorgcc /usr/lib/colorgcc/bin
+ insinto /etc/colorgcc
+ doins colorgccrc || die
+ einfo "Scanning for compiler front-ends"
+ into /usr/lib/colorgcc/bin
+ for a in gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ ; do
+ if [ -n "$(type -p ${a})" ]; then
+ dosym /usr/bin/colorgcc /usr/lib/colorgcc/bin/${a}
+ fi
+ done
+
+ dodoc CREDITS ChangeLog || die
+}
+
+pkg_postinst() {
+ echo
+ elog "If you have existing \$HOME/.colorgccrc files that set the location"
+ elog "of the compilers, you should remove those lines for maximum"
+ elog "flexibility. The colorgcc script now knows how to pass the command"
+ elog "on to the next step in the PATH without manual tweaking, making it"
+ elog "easier to use with things like ccache and distcc on a conditional"
+ elog "basis. You can tweak the /etc/colorgcc/colorgccrc file to change"
+ elog "the default settings for everyone (or copy this file as a basis for"
+ elog "a custom \$HOME/.colorgccrc file)."
+ elog
+ elog "NOTE: the symlinks for colorgcc are now located in"
+ elog "/usr/lib/colorgcc/bin *NOT* /usr/bin/wrappers. You'll need to"
+ elog "change any PATH settings that referred to the old location."
+ echo
+ # portage won't delete the old symlinks for users that are upgrading
+ # because the old symlinks still point to /usr/bin/colorgcc which exists...
+ [ -d "${EROOT}"/usr/bin/wrappers ] && rm -fr "${EROOT}"/usr/bin/wrappers
+}
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
new file mode 100644
index 000000000000..68a177ba75c7
--- /dev/null
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
@@ -0,0 +1,242 @@
+--- colorgcc.orig 1999-04-29 10:16:08.000000000 -0700
++++ colorgcc 2003-04-11 16:38:52.000000000 -0700
+@@ -88,16 +88,16 @@
+ #
+ # 1.0.0 Initial Version
+
++use strict;
++
+ use Term::ANSIColor;
+ use IPC::Open3;
++use Cwd 'abs_path';
++
++my(%nocolor, %colors, %compilerPaths);
+
+ sub initDefaults
+ {
+- $compilerPaths{"gcc"} = "/usr/local/bin/gcc";
+- $compilerPaths{"g++"} = "/usr/local/bin/g++";
+- $compilerPaths{"cc"} = "/usr/bin/cc";
+- $compilerPaths{"c++"} = "/usr/local/bin/c++";
+-
+ $nocolor{"dumb"} = "true";
+
+ $colors{"srcColor"} = color("cyan");
+@@ -125,26 +125,26 @@
+ next if (m/^\#.*/); # It's a comment.
+ next if (!m/(.*):\s*(.*)/); # It's not of the form "foo: bar".
+
+- $option = $1;
+- $value = $2;
++ my $option = $1;
++ my $value = $2;
+
+- if ($option =~ m/cc|c\+\+|gcc|g\+\+/)
+- {
+- $compilerPaths{$option} = $value;
+- }
+- elsif ($option eq "nocolor")
++ if ($option eq "nocolor")
+ {
+ # The nocolor option lists terminal types, separated by
+ # spaces, not to do color on.
+- foreach $termtype (split(/\s+/, $value))
++ foreach my $term (split(' ', $value))
+ {
+- $nocolor{$termtype} = "true";
++ $nocolor{$term} = 1;
+ }
+ }
+- else
++ elsif (defined $colors{$option})
+ {
+ $colors{$option} = color($value);
+ }
++ else
++ {
++ $compilerPaths{$option} = $value;
++ }
+ }
+ close(PREFS);
+ }
+@@ -180,41 +180,80 @@
+ initDefaults();
+
+ # Read the configuration file, if there is one.
+-$configFile = $ENV{"HOME"} . "/.colorgccrc";
++my $configFile = $ENV{"HOME"} . "/.colorgccrc";
+ if (-f $configFile)
+ {
+ loadPreferences($configFile);
+ }
++elsif (-f '/etc/colorgcc/colorgccrc')
++{
++ loadPreferences('/etc/colorgcc/colorgccrc');
++}
+
+ # Figure out which compiler to invoke based on our program name.
+ $0 =~ m%.*/(.*)$%;
+-$progName = $1 || $0;
+-
+-$compiler = $compilerPaths{$progName} || $compilerPaths{"gcc"};
+-
+-# Get the terminal type.
+-$terminal = $ENV{"TERM"} || "dumb";
++my $progName = $1 || $0;
++my $compiler_pid;
+
+-# If it's in the list of terminal types not to color, or if
+-# we're writing to something that's not a tty, don't do color.
+-if (! -t STDOUT || $nocolor{$terminal})
++# If called as "colorgcc", just filter STDIN to STDOUT.
++if ($progName eq 'colorgcc')
+ {
+- exec $compiler, @ARGV
+- or die("Couldn't exec");
++ open(GCCOUT, "<&STDIN");
+ }
++else
++{
++ # See if the user asked for a specific compiler.
++ my $compiler;
++ if (!defined($compiler = $compilerPaths{$progName}))
++ {
++ # Find our wrapper dir on the PATH and tweak the PATH to remove
++ # everything up-to and including our wrapper dir.
++ if ($0 =~ m#(.*)/#)
++ {
++ # We were called with an explicit path, so trim that off the PATH.
++ my $find = $1;
++ $find = abs_path($1) unless $find =~ m#^/#;
++ $ENV{'PATH'} =~ s#.*(^|:)\Q$find\E(:|$)##;
++ }
++ else
++ {
++ my(@dirs) = split(/:/, $ENV{'PATH'});
++ while (defined($_ = shift @dirs))
++ {
++ if (-x "$_/$progName")
++ {
++ $ENV{'PATH'} = join(':', @dirs);
++ last;
++ }
++ }
++ }
++ $compiler = $progName;
++ }
+
+-# Keep the pid of the compiler process so we can get its return
+-# code and use that as our return code.
+-$compiler_pid = open3('<&STDIN', \*GCCOUT, \*GCCOUT, $compiler, @ARGV);
++ # Get the terminal type.
++ my $terminal = $ENV{"TERM"} || "dumb";
++
++ # If it's in the list of terminal types not to color, or if
++ # we're writing to something that's not a tty, don't do color.
++ if (! -t STDOUT || $nocolor{$terminal})
++ {
++ exec $compiler, @ARGV
++ or die("Couldn't exec");
++ }
++
++ # Keep the pid of the compiler process so we can get its return
++ # code and use that as our return code.
++ $compiler_pid = open3('<&STDIN', \*GCCOUT, \*GCCOUT, $compiler, @ARGV);
++}
+
+ # Colorize the output from the compiler.
+ while(<GCCOUT>)
+ {
+- if (m/^(.*?):([0-9]+):(.*)$/) # filename:lineno:message
++ if (m#^(.+?\.[^:/ ]+):([0-9]+):(.*)$#) # filename:lineno:message
+ {
+- $field1 = $1 || "";
+- $field2 = $2 || "";
+- $field3 = $3 || "";
++ my $field1 = $1 || "";
++ my $field2 = $2 || "";
++ my $field3 = $3 || "";
+
+ if ($field3 =~ m/\s+warning:.*/)
+ {
+@@ -232,6 +271,10 @@
+ }
+ print("\n");
+ }
++ elsif (m/^:.+`.*'$/) # filename:message:
++ {
++ srcscan($_, $colors{"warningMessageColor"});
++ }
+ elsif (m/^(.*?):(.+):$/) # filename:message:
+ {
+ # No line number, treat as an "introductory" line of text.
+@@ -244,11 +287,9 @@
+ }
+ }
+
+-# Get the return code of the compiler and exit with that.
+-waitpid($compiler_pid, 0);
+-exit ($? >> 8);
+-
+-
+-
+-
+-
++if ($compiler_pid)
++{
++ # Get the return code of the compiler and exit with that.
++ waitpid($compiler_pid, 0);
++ exit ($? >> 8);
++}
+--- colorgccrc.orig 1999-04-29 10:16:08.000000000 -0700
++++ colorgccrc 2003-02-12 17:38:38.000000000 -0800
+@@ -20,12 +20,14 @@
+ # For example, srcColor: bold cyan on_yellow
+ #
+
+-# Define the paths to the actual location of the various compilers.
++# Only define the paths to the actual location of the various compilers if
++# you need to do something weird. For normal installs, we'll figure out
++# who to call next automatically.
+ # (Currently, colorgcc only understands these: g++ gcc c++ cc)
+-g++: /usr/local/bin/g++
+-gcc: /usr/local/bin/gcc
+-c++: /usr/local/bin/c++
+-cc: /usr/bin/cc
++##g++: /usr/bin/g++
++##gcc: /usr/bin/gcc
++##c++: /usr/bin/c++
++##cc: /usr/bin/cc
+
+ # Don't do color if our terminal type ($TERM) is one of these.
+ # (List all terminal types on one line, seperated by whitespace.)
+@@ -43,12 +45,10 @@
+
+ # Warnings
+ warningFileNameColor: reset
+-warningNumberColor: white
++warningNumberColor: blue
+ warningMessageColor: yellow
+
+ # Errors
+ errorFileNameColor: reset
+-errorNumberColor: white
++errorNumberColor: blue
+ errorMessageColor: bold red
+-
+-
+--- INSTALL.orig 1999-04-29 10:16:08.000000000 -0700
++++ INSTALL 2003-04-07 17:12:25.000000000 -0700
+@@ -27,9 +27,9 @@
+ When "g++" is invoked, colorgcc is run instead. colorgcc looks at the
+ program name to figure out which compiler to use.
+
+-Copy the sample colorgccrc file to $HOME/.colorgccrc and make sure the
+-absolute paths for the compilers are correct for your system.
+-See the comments in the sample .colorgccrc for more information.
++Modify the file /etc/colorgcc/colorgccrc if you want to change the default
++values for everyone. For individual customizations, copy this file to
++$HOME/.colorgccrc and change that.
+
+
+ Note:
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
new file mode 100644
index 000000000000..911a31b21bf3
--- /dev/null
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
@@ -0,0 +1,75 @@
+--- colorgcc.r9 2003-09-21 12:14:48.000000000 -0700
++++ colorgcc 2003-09-21 13:11:22.000000000 -0700
+@@ -95,6 +95,7 @@
+ use Cwd 'abs_path';
+
+ my(%nocolor, %colors, %compilerPaths);
++my($unfinishedQuote, $previousColor);
+
+ sub initDefaults
+ {
+@@ -159,14 +160,37 @@
+
+ my($line, $normalColor) = @_;
+
++ if (defined $normalColor)
++ {
++ $previousColor = $normalColor;
++ }
++ else
++ {
++ $normalColor = $previousColor;
++ }
++
+ my($srcon) = color("reset") . $colors{"srcColor"};
+ my($srcoff) = color("reset") . $normalColor;
+
+- $line = $normalColor . $line;
++ $line = ($unfinishedQuote? $srcon : $normalColor) . $line;
+
+- # This substitute replaces `foo' with `AfooB' where A is the escape
++ # These substitutions replaces `foo' with `AfooB' where A is the escape
+ # sequence that turns on the the desired source color, and B is the
+ # escape sequence that returns to $normalColor.
++
++ # Handle multi-line quotes.
++ if ($unfinishedQuote) {
++ if ($line =~ s/^([^\`]*?)\'/$1$srcoff\'/)
++ {
++ $unfinishedQuote = 0;
++ }
++ }
++ if ($line =~ s/\`([^\']*?)$/\`$srcon$1/)
++ {
++ $unfinishedQuote = 1;
++ }
++
++ # Single line quoting.
+ $line =~ s/\`(.*?)\'/\`$srcon$1$srcoff\'/g;
+
+ print($line, color("reset"));
+@@ -190,6 +214,10 @@
+ loadPreferences('/etc/colorgcc/colorgccrc');
+ }
+
++# Set our default output color. This presumes that any unrecognized output
++# is an error.
++$previousColor = $colors{"errorMessageColor"};
++
+ # Figure out which compiler to invoke based on our program name.
+ $0 =~ m%.*/(.*)$%;
+ my $progName = $1 || $0;
+@@ -281,10 +309,9 @@
+ # No line number, treat as an "introductory" line of text.
+ srcscan($_, $colors{"introColor"});
+ }
+- else # Anything else.
++ else # Anything else.
+ {
+- # Doesn't seem to be a warning or an error. Print normally.
+- print(color("reset"), $_);
++ srcscan($_, undef);
+ }
+ }
+
+
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
new file mode 100644
index 000000000000..026503e8f2c9
--- /dev/null
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
@@ -0,0 +1,57 @@
+--- /usr/bin/colorgcc 2009-10-29 20:24:46.717190000 +0100
++++ colorgcc 2009-10-29 20:27:42.614162888 +0100
+@@ -102,7 +102,8 @@
+ $nocolor{"dumb"} = "true";
+
+ $colors{"srcColor"} = color("cyan");
+- $colors{"introColor"} = color("blue");
++ $colors{"introFileNameColor"} = color("blue");
++ $colors{"introMessageColor"} = color("blue");
+
+ $colors{"warningFileNameColor"} = color("yellow");
+ $colors{"warningNumberColor"} = color("yellow");
+@@ -111,6 +112,10 @@
+ $colors{"errorFileNameColor"} = color("bold red");
+ $colors{"errorNumberColor"} = color("bold red");
+ $colors{"errorMessageColor"} = color("bold red");
++
++ $colors{"noteFileNameColor"} = color("green");
++ $colors{"noteNumberColor"} = color("green");
++ $colors{"noteMessageColor"} = color("green");
+ }
+
+ sub loadPreferences
+@@ -290,12 +295,18 @@
+ print($colors{"warningNumberColor"}, "$field2:", color("reset"));
+ srcscan($field3, $colors{"warningMessageColor"});
+ }
+- else
+- {
++ elsif ($field3 =~ m/\s+error:.*/)
++ {
+ # Error
+ print($colors{"errorFileNameColor"}, "$field1:", color("reset"));
+ print($colors{"errorNumberColor"}, "$field2:", color("reset"));
+ srcscan($field3, $colors{"errorMessageColor"});
++ } else
++ {
++ # Note
++ print($colors{"noteFileNameColor"}, "$field1:", color("reset"));
++ print($colors{"noteNumberColor"}, "$field2:", color("reset"));
++ srcscan($field3, $colors{"noteMessageColor"});
+ }
+ print("\n");
+ }
+@@ -305,8 +316,11 @@
+ }
+ elsif (m/^(.*?):(.+):$/) # filename:message:
+ {
++ my $field1 = $1 || "";
++ my $field2 = $2 || "";
+ # No line number, treat as an "introductory" line of text.
+- srcscan($_, $colors{"introColor"});
++ print($colors{"introFileNameColor"}, "$field1:", color("reset"));
++ print($colors{"introMessageColor"}, "$field2:\n", color("reset"));
+ }
+ else # Anything else.
+ {
diff --git a/dev-util/colorgcc/metadata.xml b/dev-util/colorgcc/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/dev-util/colorgcc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>