summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-06-17 09:28:23 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-06-17 09:28:23 -0400
commit46c3c10815f5a3cc307d8e37b9522b91138f699e (patch)
tree4552327da0e1ea9be078602a83d5919b553dd446 /dev-util/comparator
parentnet-misc/electrum: RDEPEND on >=dev-python/aiorpcX-0.17, bug #687004 (diff)
downloadgentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.tar.gz
gentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.tar.bz2
gentoo-46c3c10815f5a3cc307d8e37b9522b91138f699e.zip
dev-util/comparator: version bump to 2.12
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-util/comparator')
-rw-r--r--dev-util/comparator/Manifest1
-rw-r--r--dev-util/comparator/comparator-2.12.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/comparator/Manifest b/dev-util/comparator/Manifest
index 0f6495ea304f..ad7963296409 100644
--- a/dev-util/comparator/Manifest
+++ b/dev-util/comparator/Manifest
@@ -1 +1,2 @@
DIST comparator-2.10.tar.gz 1463175 BLAKE2B 58d6bddc5f785de3768ed2c4845b75af03c1fd7f646fc15efaeec09878a72355c46c64f67866217994797193aaba6d4214685c7be89be9872620dce5930238e8 SHA512 b880f7a4a0fbfad44c53606c6d97509305d8485f0ab76b62bb0d1d1d6d4be9fb81e7a08326e78cabd1a9314e6efbf3a966eb6393e424f59dc657975a63ce2988
+DIST comparator-2.12.tar.gz 1463333 BLAKE2B 081251a0a3cb2f99d5b74092a46a868741049d27c367fc9bc3445d35fe01eaaaee75f7afd3674ecdc2569c2ac1ef2d5acd838a546aa307b33c977c4c8a91db12 SHA512 dc5acf3d5900e293e3f0188c0809bc99f2f18edb55df882b2e12e66bc655e7faf030b8daffdd2d175234b398e6a8c125ca6af615933c998651d7f1579734b080
diff --git a/dev-util/comparator/comparator-2.12.ebuild b/dev-util/comparator/comparator-2.12.ebuild
new file mode 100644
index 000000000000..bbbbe0a4134a
--- /dev/null
+++ b/dev-util/comparator/comparator-2.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+src_prepare() {
+ sed \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake ROOT="${D}" install
+ distutils-r1_src_install
+ docinto html
+ dodoc *.html
+}