summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/confix/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/confix/files')
-rw-r--r--dev-util/confix/files/2.1.0/jni-hpux.patch10
-rw-r--r--dev-util/confix/files/2.3.0/exeext.patch20
-rw-r--r--dev-util/confix/files/2.3.0/ext-ac-archive.patch35
-rw-r--r--dev-util/confix/files/2.3.0/local-libs-first.patch39
-rw-r--r--dev-util/confix/files/2.3.0/new-automake.patch12
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-util/confix/files/2.1.0/jni-hpux.patch b/dev-util/confix/files/2.1.0/jni-hpux.patch
new file mode 100644
index 000000000000..bd1b626e7bc2
--- /dev/null
+++ b/dev-util/confix/files/2.1.0/jni-hpux.patch
@@ -0,0 +1,10 @@
+--- Confix-2.0.0pre20/share/confix/autoconf-archive/m4src/ac_jni_include_dir.m4.orig 2007-02-07 21:16:20.000000000 +0100
++++ Confix-2.0.0pre20/share/confix/autoconf-archive/m4src/ac_jni_include_dir.m4 2007-02-07 21:16:34.000000000 +0100
+@@ -67,6 +67,7 @@
+ mingw*) _JNI_INC_SUBDIRS="win32";;
+ cygwin*) _JNI_INC_SUBDIRS="win32";;
+ interix*) _JNI_INC_SUBDIRS="win32";;
++hpux*) _JNI_INC_SUBDIRS="hp-ux";;
+ *) _JNI_INC_SUBDIRS="genunix";;
+ esac
+
diff --git a/dev-util/confix/files/2.3.0/exeext.patch b/dev-util/confix/files/2.3.0/exeext.patch
new file mode 100644
index 000000000000..98576f5c9f8b
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/exeext.patch
@@ -0,0 +1,20 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/makefile_am.py confix-9999/libconfix/plugins/automake/makefile_am.py
+--- confix-9999.orig/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:20:42.106291175 +0100
++++ confix-9999/libconfix/plugins/automake/makefile_am.py 2009-10-30 13:23:39.562354663 +0100
+@@ -472,7 +472,15 @@
+
+ # register automatic tests and set their environment
+
+- tests = self.dir_primary('check', 'PROGRAMS') + \
++ test_tmp = self.dir_primary('check', 'PROGRAMS')
++ count = 0
++ for prog in test_tmp:
++ prog += "$(EXEEXT)"
++ test_tmp[count] = prog
++ count += 1
++ pass
++
++ tests = test_tmp + \
+ self.dir_primary('check', 'SCRIPTS')
+ if len(tests):
+ lines.extend(makefile.List(name='TESTS', values=tests, mitigate=True).lines())
diff --git a/dev-util/confix/files/2.3.0/ext-ac-archive.patch b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
new file mode 100644
index 000000000000..32122c95bfe2
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
@@ -0,0 +1,35 @@
+diff -ru confix-9999.orig/libconfix/plugins/automake/bootstrap.py confix-9999/libconfix/plugins/automake/bootstrap.py
+--- confix-9999.orig/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:25:27.962172020 +0100
++++ confix-9999/libconfix/plugins/automake/bootstrap.py 2009-10-30 13:27:14.780605001 +0100
+@@ -16,7 +16,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ # USA
+
+-import autoconf_archive
++#import autoconf_archive
+ import kde_hack
+
+ from libconfix.core.utils.error import Error
+@@ -29,7 +29,7 @@
+
+ def bootstrap(packageroot, use_kde_hack, argv0, path=None):
+ aclocal_incdirs = []
+- aclocal_incdirs.append(autoconf_archive.include_path(argv0))
++ #aclocal_incdirs.append(autoconf_archive.include_path(argv0))
+
+ # if package's configure.ac looks like using libtool, then we
+ # assume that the package must be libtoolize'd.
+diff -ru confix-9999.orig/setup.py confix-9999/setup.py
+--- confix-9999.orig/setup.py 2009-10-30 13:25:27.965360137 +0100
++++ confix-9999/setup.py 2009-10-30 13:26:47.822129311 +0100
+@@ -41,8 +41,8 @@
+ return result
+
+ datafiles = []
+-datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
+-datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/m4src', '.m4', []))
++#datafiles.extend(recdir('share/confix/autoconf-archive/htmldoc', '.html', []))
+
+ # scripts to put in the auxdir.
+ datafiles.extend([('share/confix/kde-hack',
diff --git a/dev-util/confix/files/2.3.0/local-libs-first.patch b/dev-util/confix/files/2.3.0/local-libs-first.patch
new file mode 100644
index 000000000000..29d4a7a1cc9d
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/local-libs-first.patch
@@ -0,0 +1,39 @@
+With libtool, link local libraries with /path/to/libfile.la instead of libpath,
+to avoid encoding local libpath into installed la-file.
+These also have to be linked first, to avoid finding already installed
+libraries of previous versions during libtool-relink.
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py Confix-2.3.0/libconfix/plugins/automake/c/out_c.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py 2010-07-06 12:55:59.286540943 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/c/out_c.py 2010-07-06 13:01:23.574428852 +0200
+@@ -411,6 +411,8 @@
+ """
+ assert isinstance(linked_builder, LinkedBuilder)
+
++ local_paths = []
++ local_libraries = []
+ native_paths = []
+ native_libraries = []
+ external_linkline = []
+@@ -424,8 +426,11 @@
+
+ for bi in native_libs_to_use:
+ if isinstance(bi, BuildInfo_CLibrary_NativeLocal):
+- native_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
+- native_libraries.append('-l'+bi.basename())
++ if self.__use_libtool:
++ local_libraries.append('/'.join(['$(top_builddir)']+bi.dir()+['lib'+bi.basename()+'.la']))
++ else:
++ local_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
++ local_libraries.append('-l'+bi.basename())
+ continue
+ if isinstance(bi, BuildInfo_CLibrary_NativeInstalled):
+ using_installed_library = True
+@@ -447,7 +452,7 @@
+ external_linkline.extend(elem)
+ pass
+
+- return native_paths + native_libraries + external_linkline
++ return local_paths + local_libraries + native_paths + native_libraries + external_linkline
+
+ def external_libpath(self):
+ """ For unit tests only. """
diff --git a/dev-util/confix/files/2.3.0/new-automake.patch b/dev-util/confix/files/2.3.0/new-automake.patch
new file mode 100644
index 000000000000..d6f24a4cae81
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/new-automake.patch
@@ -0,0 +1,12 @@
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py Confix-2.3.0/libconfix/plugins/automake/out_automake.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py 2010-07-12 13:15:49.254867387 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/out_automake.py 2010-07-12 13:17:29.755908602 +0200
+@@ -170,7 +170,7 @@
+
+
+ # our minimum required automake version is 1.9
+- self.makefile_am().add_automake_options('1.9')
++ # self.makefile_am().add_automake_options('1.9')
+
+
+ # enable dist'ing in the following formats