summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-05-21 01:18:44 +0200
committerSebastian Pipping <sping@gentoo.org>2020-05-21 01:19:33 +0200
commitb4e532024ce45cfcea858711bd315124a851b891 (patch)
treec5ca40846bf57f0096aab2717ec056b6c74b506d /dev-util/cpptest
parentdev-util/ply: add static-libs USE flag (diff)
downloadgentoo-b4e532024ce45cfcea858711bd315124a851b891.tar.gz
gentoo-b4e532024ce45cfcea858711bd315124a851b891.tar.bz2
gentoo-b4e532024ce45cfcea858711bd315124a851b891.zip
dev-util/cpptest: Support USE=-static-libs
Closes: https://bugs.gentoo.org/724290 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to 'dev-util/cpptest')
-rw-r--r--dev-util/cpptest/cpptest-2.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-2.0.0-r1.ebuild b/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..e98152705084
--- /dev/null
+++ b/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="https://github.com/cpptest/cpptest"
+SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1" # for soversion 1.x.x
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="!dev-util/cpptest:0"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+ econf $(use_enable doc) $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}