summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-09-02 11:55:29 +0000
committerSam James <sam@gentoo.org>2020-09-09 01:03:05 +0000
commit1de3f18466379593f24c382f66e069dc9ba1b181 (patch)
treebc3c67b08751092af49974bc1ad69028ed8cf9fb /dev-util/cram
parentmedia-gfx/openvdb: Use full path for Python_EXECUTABLE (diff)
downloadgentoo-1de3f18466379593f24c382f66e069dc9ba1b181.tar.gz
gentoo-1de3f18466379593f24c382f66e069dc9ba1b181.tar.bz2
gentoo-1de3f18466379593f24c382f66e069dc9ba1b181.zip
dev-util/cram: add python3.9 support
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/cram')
-rw-r--r--dev-util/cram/cram-0.7-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/cram/cram-0.7-r1.ebuild b/dev-util/cram/cram-0.7-r1.ebuild
new file mode 100644
index 000000000000..008e8aa0cfd7
--- /dev/null
+++ b/dev-util/cram/cram-0.7-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Functional testing framework for command line applications"
+HOMEPAGE="https://bitheap.org/cram/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+}