summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/crow-designer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/crow-designer')
-rw-r--r--dev-util/crow-designer/Manifest2
-rw-r--r--dev-util/crow-designer/crow-designer-2.21.0.ebuild40
-rw-r--r--dev-util/crow-designer/crow-designer-2.99.0.ebuild40
-rw-r--r--dev-util/crow-designer/metadata.xml18
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/crow-designer/Manifest b/dev-util/crow-designer/Manifest
new file mode 100644
index 000000000000..d2fecff83162
--- /dev/null
+++ b/dev-util/crow-designer/Manifest
@@ -0,0 +1,2 @@
+DIST crow-2.21.0.tar.bz2 441555 SHA256 b3d84a80fd9a721199d2d3534fc2eea8f87434ba6896a34cd727bebeaa7ef194 SHA512 cfe7ba53185b9238f1df13265ca91deb7f1ff6ebc1808da423ef617d0bc750a62ba4827e32e52fdf34dd3d81aa86a551e67fd0074b6ac8da37821c0d9ff5cbd3 WHIRLPOOL a89fbb4966b14e1f7b80dff6b161c4dbe5a50bd4d04bcd3bbb5ed36557b40a2bc47a9a031a005b7481c5aae201e4f91fb846f0ab57f1503e06930516cba1b485
+DIST crow-2.99.0.tar.xz 391644 SHA256 19ed270b4cb446fa9855a2df9b8cc68f66d0b1a318f4df66e523923e5b28f1aa SHA512 3d90ae0f5bb8e474b55fead29ff062f8779f70db17a6548ef3d084fa7a593fd244c5ba2e704c45ee6cbe289df97c8c78dc6010fac657b91e05ab9ea0a65d9f55 WHIRLPOOL 740572d001fa7c860a4338895ba4a37139b3bf4c3de9d604090610a67df7d1243a9194c3bb2ecf505f60a7f95865172ceeb7a32c0fcb960ddb94d456964f0291
diff --git a/dev-util/crow-designer/crow-designer-2.21.0.ebuild b/dev-util/crow-designer/crow-designer-2.21.0.ebuild
new file mode 100644
index 000000000000..83628a6bb64a
--- /dev/null
+++ b/dev-util/crow-designer/crow-designer-2.21.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DESCRIPTION="GTK+ GUI building tool"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/crow-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=dev-libs/guiloader-2.21
+ >=dev-libs/guiloader-c++-2.21
+ dev-cpp/gtkmm:2.4
+ >=dev-libs/dbus-glib-0.86"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+S=${WORKDIR}/crow-${PV}
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.{en,ru}.txt,readme.{en,ru}.txt,readme.ru.txt} || die
+}
diff --git a/dev-util/crow-designer/crow-designer-2.99.0.ebuild b/dev-util/crow-designer/crow-designer-2.99.0.ebuild
new file mode 100644
index 000000000000..22fa6654e723
--- /dev/null
+++ b/dev-util/crow-designer/crow-designer-2.99.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="GTK+ GUI building tool"
+HOMEPAGE="http://www.crowdesigner.org"
+SRC_URI="http://nothing-personal.googlecode.com/files/crow-${PV}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+LANGS="ru"
+
+RDEPEND=">=dev-libs/guiloader-2.99
+ >=dev-libs/guiloader-c++-2.99
+ dev-cpp/gtkmm:3.0
+ >=dev-libs/dbus-glib-0.92"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.18 )"
+
+S=${WORKDIR}/crow-${PV}
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{authors.txt,news.{en,ru}.txt,readme.{en,ru}.txt,readme.ru.txt}
+}
diff --git a/dev-util/crow-designer/metadata.xml b/dev-util/crow-designer/metadata.xml
new file mode 100644
index 000000000000..7c9e19f15732
--- /dev/null
+++ b/dev-util/crow-designer/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">Gideon is a modern GUI builder for GTK+ toolkit. It is an advanced
+ IDE-embeddable RAD tool designed to fulfil l the needs of desktop
+ programmers who want to create multi-platform GTK+ based applications
+ with minimal GUI coding. Gideon is full-featured yet elegant: its
+ innovative Property Explorer solves many GUI constructing t asks in a
+ versatile manner without additional popup dialogs. The project is
+ targeted to develop a tool that i s coherent and highly productive for
+ experienced GTK+ users as well as simple and accessible for newcomers.</longdescription>
+ <upstream>
+ <remote-id type="google-code">nothing-personal</remote-id>
+ </upstream>
+</pkgmetadata>