summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cwdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cwdiff')
-rw-r--r--dev-util/cwdiff/Manifest2
-rw-r--r--dev-util/cwdiff/cwdiff-0.2.8.ebuild33
-rw-r--r--dev-util/cwdiff/cwdiff-0.3.0.ebuild37
-rw-r--r--dev-util/cwdiff/metadata.xml15
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-util/cwdiff/Manifest b/dev-util/cwdiff/Manifest
new file mode 100644
index 000000000000..004e7097a936
--- /dev/null
+++ b/dev-util/cwdiff/Manifest
@@ -0,0 +1,2 @@
+DIST cwdiff-0.2.8.tar.gz 4246 SHA256 cdfd1489420591b36a56370c647b361f87c0c4074fed220e9c09f3e7ea8f2c22 SHA512 bb1fb3790cc2d8f4e5f199e7abc9bf6a999ded0d25fc9e62ca1e003505f1d33b6c8575b0172a2e55128c4e5c853147304c928d0f1094c5b30e6a015b9fbcae09 WHIRLPOOL 7dec074fa079bb1468179efe6f559010b2d8267343ea5c77ad72810301baf49cb63977c7617bdc41321c944fdd067c6202d8a87b6bd5200f561176fac2fc115a
+DIST cwdiff-0.3.0.tar.gz 4666 SHA256 32c70aeae4e445a439aeed7f9b01395cc74645033533cc37b6974671cf2cfd9b SHA512 40401a0541209c83cd78ff55c62ce71dd362cf8674b07c1cdd56ad7a505741e818003f07c87fe0303cd2bfd911d99b8f560697612b32b6fee794a7671e7e86f0 WHIRLPOOL aad2e3c5c6d8dc94f70c8b272969598bf134f73bc0fc030d5f4087d341a2074736e5b409afc99c8039f250c2f0154b22d86b153e7ac3e4edc12f4c0642be2e76
diff --git a/dev-util/cwdiff/cwdiff-0.2.8.ebuild b/dev-util/cwdiff/cwdiff-0.2.8.ebuild
new file mode 100644
index 000000000000..860a9929d8e3
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.2.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+IUSE="a2ps mercurial"
+
+DEPEND=""
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install () {
+ dobin "${PN}"
+ if use mercurial ; then
+ insinto /etc/mercurial/hgrc.d
+ doins hgrc.d/"${PN}".rc
+ fi
+ dodoc README.md
+}
diff --git a/dev-util/cwdiff/cwdiff-0.3.0.ebuild b/dev-util/cwdiff/cwdiff-0.3.0.ebuild
new file mode 100644
index 000000000000..80e7cc94173b
--- /dev/null
+++ b/dev-util/cwdiff/cwdiff-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/junghans/${PN}.git http://github.com/junghans/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
+HOMEPAGE="https://github.com/junghans/cwdiff"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="a2ps mercurial"
+
+DEPEND="sys-apps/help2man
+ sys-apps/coreutils"
+RDEPEND="
+ sys-apps/sed
+ app-shells/bash
+ app-text/wdiff
+ sys-apps/diffutils
+ a2ps? ( app-text/a2ps )
+ mercurial? ( dev-vcs/mercurial )
+ "
+
+src_install() {
+ emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
+ dodoc README.md
+}
diff --git a/dev-util/cwdiff/metadata.xml b/dev-util/cwdiff/metadata.xml
new file mode 100644
index 000000000000..ee07c168e0b4
--- /dev/null
+++ b/dev-util/cwdiff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='a2ps'>install <pkg>app-text/a2ps</pkg> for postscript output</flag>
+ <flag name='mercurial'>install hg wdiff alias for <pkg>dev-vcs/mercurial</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">junghans/cwdiff</remote-id>
+ </upstream>
+</pkgmetadata>