summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/d-feet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/d-feet')
-rw-r--r--dev-util/d-feet/Manifest2
-rw-r--r--dev-util/d-feet/d-feet-0.3.10.ebuild58
-rw-r--r--dev-util/d-feet/d-feet-0.3.9.ebuild48
-rw-r--r--dev-util/d-feet/metadata.xml10
4 files changed, 118 insertions, 0 deletions
diff --git a/dev-util/d-feet/Manifest b/dev-util/d-feet/Manifest
new file mode 100644
index 000000000000..a9527600447d
--- /dev/null
+++ b/dev-util/d-feet/Manifest
@@ -0,0 +1,2 @@
+DIST d-feet-0.3.10.tar.xz 179500 SHA256 88f0df5fcb862387ff3d1793873c5eb368c3e4db0bbd82ea65f748cbf70a6359 SHA512 7a6832367b32eae204c456598ac4ad38ead585e916e2d2179203f63f4e87f2e9d9afbc8448324660552ebe4aaf2bd394f73e48f325513c3b0f5fa33f91fce40b WHIRLPOOL 559135be86d13bb7e2ff1c10d753d1c770e2fc0d0a849b643c626fb5db5e3779e5f7b7208086d6e2e92e3f1f81e06f5cb9e3cbc41510c0acab30b3b71fdf99ca
+DIST d-feet-0.3.9.tar.xz 176652 SHA256 6df917fc1c2ef43217fbeea94dc12ecfc2d136cac4c84dac2c89f03dfbca7953 SHA512 fa61f926dd0493ae5de3d81676aad78879062ade30f77e4054d1ca20e80b876c30fb61b4780a7e33a610c50f3d7df3b7cee10e91cfc69759a1228b38e9b2e1ab WHIRLPOOL 7bd1d5c7246138f4b80d1a0d1fb52de604b5b127bd6b7d8629966e42e257631efd2fc38b5d8de2d572a727a4830668dce981d4cfc42f8017897b81865039f42d
diff --git a/dev-util/d-feet/d-feet-0.3.10.ebuild b/dev-util/d-feet/d-feet-0.3.10.ebuild
new file mode 100644
index 000000000000..2411fd264582
--- /dev/null
+++ b/dev-util/d-feet/d-feet-0.3.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="D-Feet is a powerful D-Bus debugger"
+HOMEPAGE="https://wiki.gnome.org/Apps/DFeet"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=dev-python/pygobject-3.3.91:3[${PYTHON_USEDEP}]
+ >=sys-apps/dbus-1
+ >=x11-libs/gtk+-3.9.4:3[introspection]
+ x11-libs/libwnck:3[introspection]
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+"
+
+src_prepare() {
+ python_fix_shebang .
+
+ # Do not run update-desktop-database (sandbox violation)
+ sed -e '/^UPDATE_DESKTOP/s:=.*:=true:' \
+ -i data/Makefile.am data/Makefile.in || die
+
+ # disable pep8 - checking python whitespace style is not useful for us
+ sed -e 's/pep8 /# pep8 /' \
+ -i src/tests/Makefile.am src/tests/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # disable pep8 - checking python code style is not useful downstream
+ # (especially when that style check fails!)
+ gnome2_src_configure \
+ $(use_enable test tests) \
+ PEP8=$(type -P true)
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/dev-util/d-feet/d-feet-0.3.9.ebuild b/dev-util/d-feet/d-feet-0.3.9.ebuild
new file mode 100644
index 000000000000..43e0c906bf47
--- /dev/null
+++ b/dev-util/d-feet/d-feet-0.3.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="D-Feet is a powerful D-Bus debugger"
+HOMEPAGE="https://wiki.gnome.org/Apps/DFeet"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=dev-python/pygobject-3.3.91:3[${PYTHON_USEDEP}]
+ >=sys-apps/dbus-1
+ >=x11-libs/gtk+-3.9.4:3[introspection]
+ x11-libs/libwnck:3[introspection]
+"
+DEPEND="
+ ${PYTHON_DEPS}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.0
+ test? ( dev-python/pep8 )
+"
+
+src_prepare() {
+ python_fix_shebang .
+
+ # Do not run update-desktop-database (sandbox violation)
+ sed -e '/^UPDATE_DESKTOP/s:=.*:=true:' \
+ -i data/Makefile.am data/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable test tests)
+}
diff --git a/dev-util/d-feet/metadata.xml b/dev-util/d-feet/metadata.xml
new file mode 100644
index 000000000000..9dac5c8a2bd2
--- /dev/null
+++ b/dev-util/d-feet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ <description>Feel free to bump or do any updates as needed</description>
+</maintainer>
+</pkgmetadata>