summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-19 08:29:58 +0100
committerJeroen Roovers <jer@gentoo.org>2016-03-19 08:29:58 +0100
commit956d618bf3470681f8971f9914064a83229b68fe (patch)
tree917f3f126717840ef5f14dcb6c2832041348fcd1 /dev-util/debhelper
parentpackage.mask: security mask app-forensics/chkrootkit per bug #512356 (diff)
downloadgentoo-956d618bf3470681f8971f9914064a83229b68fe.tar.gz
gentoo-956d618bf3470681f8971f9914064a83229b68fe.tar.bz2
gentoo-956d618bf3470681f8971f9914064a83229b68fe.zip
dev-util/debhelper: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/debhelper')
-rw-r--r--dev-util/debhelper/Manifest1
-rw-r--r--dev-util/debhelper/debhelper-9.20160313.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/debhelper/Manifest b/dev-util/debhelper/Manifest
index 85db8ccbf5de..c06555aebffc 100644
--- a/dev-util/debhelper/Manifest
+++ b/dev-util/debhelper/Manifest
@@ -1,3 +1,4 @@
DIST debhelper_9.20150101.tar.gz 545089 SHA256 fd8d81d71d1bb0ba4b58c517465551231dd60811b98c867e4344bc55ec6a45f2 SHA512 62c85f751627cf0bdac392c6e8c5298995030962b7753047414e740b3767d722c209329c9f0c3c07c94e82bbb7250c163ce49b681e268a0decdbd19b72ea132a WHIRLPOOL 31315544c3ee695a53ef2310ad69e59c68fb0b73399305b9fe57ceb7b01faab72995e01aed270300dd0fbaed2686a5b565a8a08cfc31c720c5baa2a6c475ac4e
DIST debhelper_9.20151225.tar.xz 331624 SHA256 9c82f3543fe97a3ea4ddfda630aeac8e1c6d5ab7f7ea0c98c6cc8007731b9690 SHA512 b18ce3cdc2f24f06e75226d6687166c6567b80d5f40d2584afd4a4cffcacaf6e410b32206c37adc4dedec75b894722dd61f081344dd945a8de277a95859d1e4f WHIRLPOOL 0bbdc573a93665b59a3166361aea3c667907677a522ea67289677a849212fcda5e9fe8b182bd9863c20f49ccd0897e2269d786d21dde747b3120e74901516983
DIST debhelper_9.20160115.tar.xz 334540 SHA256 80f2c86caa5878bd41029f96c06ec709bc05fe6f83a366b74e14d4dd989f9302 SHA512 7bcfae18a5602527eaa5c37dff24f304827d3b54b8bb31f39ba87667b0160039f8e22bd52fddeced0f234811a439409e706763b4d3cc8987c67a5f836a8bcaf6 WHIRLPOOL 97139276a7c85b4ff72cc21392ea4b0013092a8327324a34e45936ba2b3291126df7a96b24c4ec54dd933254b869a73eb739dc0c0ca5b6e1f14881816a86c99d
+DIST debhelper_9.20160313.tar.xz 335852 SHA256 27b70f3dda87ec8d0647c5e006eacd494335f3e977a80bc83ed31330f2a0c532 SHA512 4d8b2289a3e60ae642a2a39f8eeb150463d6fe088c3fd2403cf9c7718532b9e995e2ae437064a8a0100a04a2b9b9753c529919ebbb835513d54db41d84f7e4f4 WHIRLPOOL 6ff10fdaddc719369bbc7d05978547178a011a8cf6a8e4b73fa7b78f66c82f16f6dfffd64bdcd147ee5f275c5bb372bc2b9f79d715f567465cbea14499ee5896
diff --git a/dev-util/debhelper/debhelper-9.20160313.ebuild b/dev-util/debhelper/debhelper-9.20160313.ebuild
new file mode 100644
index 000000000000..e4d35753a4d6
--- /dev/null
+++ b/dev-util/debhelper/debhelper-9.20160313.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Collection of programs that can be used to automate common tasks in debian/rules"
+HOMEPAGE="http://packages.qa.debian.org/d/debhelper.html http://joeyh.name/code/debhelper/"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+DH_LINGUAS=( de es fr )
+IUSE+=" ${DH_LINGUAS[@]/#/linguas_}"
+
+NLS_DEPEND=$(
+ printf "linguas_%s? ( >=app-text/po4a-0.24 )\n" ${DH_LINGUAS[@]}
+)
+
+RDEPEND="
+ >=dev-lang/perl-5.10:=
+ >=app-arch/dpkg-1.17
+ dev-perl/TimeDate
+ virtual/perl-Getopt-Long
+"
+DEPEND="${RDEPEND}
+ ${NLS_DEPEND}
+ test? ( dev-perl/Test-Pod )
+"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ tc-export CC
+
+ local LANGS="" USE_NLS=no lingua
+ for lingua in ${DH_LINGUAS[@]}; do
+ if use linguas_${lingua}; then
+ LANGS+=" ${lingua}"
+ USE_NLS=yes
+ fi
+ done
+
+ emake USE_NLS="${USE_NLS}" LANGS="${LANGS}" build
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc doc/* debian/changelog
+ docinto examples
+ dodoc examples/*
+ local lingua
+ for manfile in *.1 *.7 ; do
+ for lingua in ${DH_LINGUAS[@]}; do
+ case ${manfile} in
+ *.${lingua}.?)
+ use linguas_${lingua} \
+ && cp ${manfile} "${T}"/${manfile/.${lingua}/} \
+ && doman -i18n=${lingua} "${T}"/${manfile/.${lingua}/}
+ ;;
+ *)
+ doman ${manfile}
+ ;;
+ esac
+ done
+ done
+}