summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-06 13:03:56 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-06 13:18:25 +0200
commit0f1dfa06ffbd0806e7ebaff1398cacb48fd5c8a2 (patch)
tree16d22b4c0fce0dd210c1ffd38ad916b854c9189e /dev-util/debootstrap/debootstrap-1.0.106.ebuild
parentsci-physics/root: keep fonts dir, bug 643562 (diff)
downloadgentoo-0f1dfa06ffbd0806e7ebaff1398cacb48fd5c8a2.tar.gz
gentoo-0f1dfa06ffbd0806e7ebaff1398cacb48fd5c8a2.tar.bz2
gentoo-0f1dfa06ffbd0806e7ebaff1398cacb48fd5c8a2.zip
dev-util/debootstrap: Version 1.0.106.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-util/debootstrap/debootstrap-1.0.106.ebuild')
-rw-r--r--dev-util/debootstrap/debootstrap-1.0.106.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/debootstrap/debootstrap-1.0.106.ebuild b/dev-util/debootstrap/debootstrap-1.0.106.ebuild
new file mode 100644
index 000000000000..93ffd5d2d1aa
--- /dev/null
+++ b/dev-util/debootstrap/debootstrap-1.0.106.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Debian/Ubuntu bootstrap scripts"
+HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz
+ mirror://gentoo/devices.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-arch/dpkg
+ net-misc/wget
+ sys-devel/binutils
+"
+DOCS=( TODO debian/changelog )
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+ cp "${DISTDIR}"/devices.tar.gz "${S}"
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ default
+ doman debootstrap.8
+}
+
+pkg_postinst() {
+ if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then
+ elog "To check Release files against a keyring (--keyring=K), please"
+ elog "install app-crypt/gnupg"
+ fi
+
+ if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then
+ elog "To check Release files from Debian or Ubuntu, please install"
+ elog " app-crypt/debian-archive-keyring or"
+ elog " app-crypt/ubuntu-keyring as required"
+ fi
+}