summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-29 12:42:20 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-29 19:48:08 -0400
commit351a580acab57f68f1f9773ecd8f06115615400c (patch)
tree84b7fea71a1ecfa17707da9ab01ff26bbaeb1409 /dev-util/devhelp
parentgames-fps/alephone-marathon: style tweak (diff)
downloadgentoo-351a580acab57f68f1f9773ecd8f06115615400c.tar.gz
gentoo-351a580acab57f68f1f9773ecd8f06115615400c.tar.bz2
gentoo-351a580acab57f68f1f9773ecd8f06115615400c.zip
dev-util/devhelp: Version bump to 41.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/devhelp')
-rw-r--r--dev-util/devhelp/Manifest1
-rw-r--r--dev-util/devhelp/devhelp-41.3.ebuild83
-rw-r--r--dev-util/devhelp/files/41.3-webkitgtk40.patch34
3 files changed, 118 insertions, 0 deletions
diff --git a/dev-util/devhelp/Manifest b/dev-util/devhelp/Manifest
index 9e1facd9d301..98bd8fd423b8 100644
--- a/dev-util/devhelp/Manifest
+++ b/dev-util/devhelp/Manifest
@@ -1 +1,2 @@
DIST devhelp-41.2.tar.xz 1455736 BLAKE2B c531af6cded6c9624581e4d14fb4d7713afbdcf173ec2a82e49789af1752568790dc346cc0293eddc68c0943fec4f742de726953de34441771711a938ba858fa SHA512 99a75ff19bf1b4613c312921452f190334e3e2036c28cda070169e3d1d352a5d2e7a56a393326efd679076257412e281dc94b628429119fcad58060d1a88ea98
+DIST devhelp-41.3.tar.xz 2303068 BLAKE2B 1c08931897a7cd1d15028d9394479297d6fffc48412aa31cc739380405b8588fec47fddbea803c80d44eb23d2fa84d5f9a42aa8b061859d459e450ccd76ee82d SHA512 91251f1d8c0380f16768a1fed2d0a0a19935a646613a966c48ae70e52bfe8b6aa0c683d2b371d9e25dfdfcaeac687ea2c83c2bfd5f4f35394bb4576e6f98b48d
diff --git a/dev-util/devhelp/devhelp-41.3.ebuild b/dev-util/devhelp/devhelp-41.3.ebuild
new file mode 100644
index 000000000000..b9eb3583a6e9
--- /dev/null
+++ b/dev-util/devhelp/devhelp-41.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="An API documentation browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0/3-6" # subslot = 3-(libdevhelp-3 soname version)
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="+gedit gtk-doc +introspection"
+REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} ) gtk-doc? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=net-libs/webkit-gtk-2.26:4[introspection?]
+ gnome-base/gsettings-desktop-schemas
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ gedit? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[introspection(+),python,${PYTHON_SINGLE_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ dev-util/itstool
+ gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/41.2-optional-introspection.patch
+ "${FILESDIR}"/${PV}-webkitgtk40.patch
+)
+
+pkg_setup() {
+ use gedit && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dflatpak_build=false
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dplugin_emacs=true
+ $(meson_use gedit plugin_gedit)
+ -Dplugin_vim=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die
+ mv "${ED}"/usr/share/doc/devhelp-3 "${ED}"/usr/share/gtk-doc/html/ || die
+ fi
+ use gedit && python_optimize "${ED}"/usr/$(get_libdir)/gedit/plugins
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/dev-util/devhelp/files/41.3-webkitgtk40.patch b/dev-util/devhelp/files/41.3-webkitgtk40.patch
new file mode 100644
index 000000000000..bd798e8ce7cf
--- /dev/null
+++ b/dev-util/devhelp/files/41.3-webkitgtk40.patch
@@ -0,0 +1,34 @@
+From bdb13ad7f18c90d6409da713ac49dc3995d2dfe2 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 3 Oct 2021 23:52:27 +0300
+Subject: [PATCH] build: Don't automagically depend on webkit2gtk-4.1
+
+That's the libsoup3 using webkit-gtk SLOT that we don't have. Patch it out,
+so it wouldn't be picked up automagically once it's added or comes from some
+overlay.
+
+This reverts commit f9d52aad23914df9dcb404723d1c99cf7b4e1eca.
+---
+ meson.build | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 307a351a..64dc385a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -46,12 +46,8 @@ lt_revision = 3
+ lt_age = 0
+ LIBDEVHELP_LT_VERSION = '@0@.@1@.@2@'.format(lt_current, lt_revision, lt_age)
+
+-webkit_dep = dependency('webkit2gtk-4.1', required : false)
+-webkit_abi = '4.1'
+-if not webkit_dep.found()
+ webkit_abi = '4.0'
+ webkit_dep = dependency('webkit2gtk-4.0')
+-endif
+
+ LIBDEVHELP_PUBLIC_DEPS = [
+ dependency('gio-2.0', version: '>= 2.64'),
+--
+2.35.1
+